Pro/ENGINEER® Wildfire® 4.0

ECAD
Help Topic Collection

Parametric Technology Corporation
# Table of Contents

ECAD .......................................................................................................................... 1

Using Pro/ENGINEER ECAD .................................................................................. 2
  About Pro/ENGINEER ECAD in the Design Process ........................................ 2
  ECAD-MCAD Collaboration ............................................................................. 3
  Suggested Design Sequence ........................................................................... 3
  About Setting Defaults for Faster Import ...................................................... 3
  About Fixing Import Problems in Sketcher ................................................... 4
  Tip: The ECAD Log File ................................................................................ 5
  Tip: The Z-Axis Offset in IDF ...................................................................... 5
  Tip: Parametric Dimensions in ECAD ........................................................... 5
  Model Parameters .......................................................................................... 6
  Feature Parameters ......................................................................................... 6
  Component Feature Parameters ................................................................... 8
  To Perform a Clearance-Interference Check ................................................... 8

Configuring Pro/ENGINEER ECAD ..................................................................... 9
  About Configuring Pro/ENGINEER ECAD ..................................................... 9
  To Set Pro/ENGINEER ECAD Configuration Options .................................... 9
dazix_default_placement_unit ........................................................................ 9
dazix_export_mounthole ................................................................................ 9
dazix_z_translation ........................................................................................ 10
ecad_area_default_import ............................................................................ 10
ecad_board_csys_def_name ......................................................................... 10
ecad_comp_csys_def_name ......................................................................... 10
ecad_comp_layer_map ................................................................................... 10
ecad_comp_xsec_def_name .......................................................................... 10
ecad_create_hint_add ................................................................................... 11
ecad_default_comp_height .......................................................................... 11
ecad_default_comp_place_status .................................................................. 11
ecad_exp_both_two_areas ............................................................................ 11
# Table of Contents

- `ecad_export_cuts_as_holes` ................................................................. 11
- `ecad_export_holes_as_cuts` ................................................................. 11
- `ecad_import_holes_as_features` .......................................................... 12
- `ecad_import_relative_accuracy` ......................................................... 12
- `ecad_load_filtered_holes_to_ui` ......................................................... 12
- `ecad_mapping_file` ........................................................................... 12
- `ecad_missing_component_status` ....................................................... 13
- `ecad_outline_holes_exp_method` ....................................................... 13
- `ecad_panel_csys_def_name` ............................................................... 13
- `ecad_pin_hole_import` ....................................................................... 13
- `ecad_via_hole_import` ....................................................................... 13
- `ecad_use_legacy_formats` ................................................................. 14
- `ecad_other_outl_csys_def_name` ......................................................... 14
- `mentor_ver_2_0` ............................................................................... 14
- `template_ecadasm` ........................................................................... 14
- `template_ecadpart` ........................................................................... 14

## Importing ECAD Databases .............................................................. 14

- About Importing ECAD Databases ..................................................... 14
- Board Assembly Files and Library Files ............................................ 14
- 3D Integrated Circuit (3DIC) Designs ............................................... 15
- Automatic or Partial Assembly on Import ......................................... 15
- Automatic Part Creation ................................................................... 15
- Custom Part Substitution .................................................................. 15
- Automatic Layer Assignment ............................................................ 15
- Additional Supported Objects for Import-Export ............................... 16

## Using Automatic Layer Assignment ............................................... 16

- Using the `ecad_hint.map` File ............................................................ 17
- Using Coordinate Systems ................................................................. 17
- Top and Bottom Side ........................................................................ 19
- Naming Default Coordinate Systems ............................................... 19

## To Import a PCB or Panel Assembly ............................................... 20
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>To Import a Board Outline</td>
<td>20</td>
</tr>
<tr>
<td>To Import a Panel Outline</td>
<td>22</td>
</tr>
<tr>
<td>To Import Components as Parts</td>
<td>23</td>
</tr>
<tr>
<td>To Import Components Into an Assembly</td>
<td>23</td>
</tr>
<tr>
<td>To Substitute Custom Pro/ENGINEER Parts</td>
<td>25</td>
</tr>
<tr>
<td>To Import a Non-Electrical Volume</td>
<td>25</td>
</tr>
<tr>
<td>To Specify Parts as Electrical or Mechanical</td>
<td>26</td>
</tr>
<tr>
<td>To Show or Hide Reference Designators</td>
<td>26</td>
</tr>
<tr>
<td>To Assign or Rename a Reference Designator</td>
<td>27</td>
</tr>
<tr>
<td>To Manipulate a Reference Designator</td>
<td>27</td>
</tr>
<tr>
<td>In the Assembly Mode</td>
<td>27</td>
</tr>
<tr>
<td>In the Drawing Mode</td>
<td>28</td>
</tr>
<tr>
<td>To Import Using Investigate Mode</td>
<td>29</td>
</tr>
<tr>
<td>In Assembly Mode</td>
<td>29</td>
</tr>
<tr>
<td>Status Color Descriptions</td>
<td>30</td>
</tr>
<tr>
<td>In Part Mode</td>
<td>30</td>
</tr>
<tr>
<td>Selective Import of Holes</td>
<td>31</td>
</tr>
<tr>
<td>About the Selective Import of Holes from Board Outlines</td>
<td>31</td>
</tr>
<tr>
<td>To Selectively Import Holes While Importing a Board</td>
<td>32</td>
</tr>
<tr>
<td>To Define Rules for the Filtration of Holes by Diameters</td>
<td>34</td>
</tr>
<tr>
<td>To Import Other Outlines from the Board</td>
<td>35</td>
</tr>
<tr>
<td>Configuring the Selective Import of Holes</td>
<td>36</td>
</tr>
<tr>
<td>About Importing Holes According to Priority</td>
<td>37</td>
</tr>
<tr>
<td>Importing and Visualizing 3DIC Designs</td>
<td>38</td>
</tr>
<tr>
<td>About Importing 3-Dimensional Integrated Circuit (3DIC) Designs</td>
<td>38</td>
</tr>
<tr>
<td>About IC Layers</td>
<td>38</td>
</tr>
<tr>
<td>About IC Structures</td>
<td>38</td>
</tr>
<tr>
<td>To Import a 3DIC Design into Pro/ENGINEER</td>
<td>39</td>
</tr>
<tr>
<td>About Visualizing the Imported 3DIC Designs in Pro/ENGINEER</td>
<td>39</td>
</tr>
<tr>
<td>Placement of Layers and Structures in the Design</td>
<td>40</td>
</tr>
<tr>
<td>Instancing and Transforming Structures</td>
<td>40</td>
</tr>
</tbody>
</table>
Table of Contents

Inclusion of a Layer in Many Structures .................................................................40
Boundary and Path Representations .................................................................41
Thermal Conductivity and Material Properties of Layers ..................................41
Model Length and Material Property Units ....................................................41
Limitations in Representation ........................................................................42
About Using the OpenAccess Format ..............................................................42
Converting GDS2-based IC Formats to OA ..................................................43
Troubleshooting the Import of 3DIC Designs ................................................43
Using Keepin and Keepout Areas ....................................................................45
About Keepin and Keepout Areas ..................................................................45
To Add a Keepin or Keepout Area ................................................................46
To Assign a Group Name to an ECAD Area ................................................47
Exporting Data to ECAD ................................................................................47
About Exporting ECAD Data ........................................................................47
To Export Board Outline and Component Assembly Data ..........................48
To Export Board or Component Parts ..........................................................48
To Export a Panel File in Assembly Mode ..................................................49
To Export a Panel File in Part Mode ...............................................................50
Tip: Placing Subassemblies as Components for Export ...............................50
About Exporting ECAD Data to the EDA Format ..........................................51
To Export ECAD Data to the EDA Format ....................................................51
Exporting Board and Components to EDA Format .......................................52
Board Outlines that Include Extruded Sections and Cutouts .......................52
Component Placement ....................................................................................52
Component Outlines .....................................................................................53
Exporting Holes and ECAD Areas to EDA Format .......................................53
Hole Features ...............................................................................................53
ECAD Areas .................................................................................................53
Other Outlines and Notes ............................................................................54
Exporting Irregularly Shaped Components ..................................................54
To Add a Cross-Section to Export Irregularly Shaped Components .............54
# Table of Contents

- Working in ECAD-MCAD Collaboration Mode ...................................................55
- About the ECAD-MCAD Collaboration Mode ...................................................55
- About the Sequence of Collaborative Tasks ..................................................56
- Proposing Incremental Changes from Pro/ENGINEER .................................57
- Proposing Incremental Changes from ECAD ................................................58
- About Comparing ECAD Assembly Designs ..............................................59
- To Set the Baseline EDA File for the Comparison ........................................59
- To Compare the Current ECAD Assembly With its Baseline .......................59
- Editing the Settings for Units ......................................................................60
- About the IDX Format...............................................................................61
- About Validating Proposed Design Changes ..............................................61
- About the Design States............................................................................62
- To Validate Proposed Design Changes .......................................................63
- About the Incremental Update of the IDX File and ECAD Assembly ............64
- To Incrementally Update the IDX File and the ECAD Assembly ..................65
- About Board and Component Changes ......................................................66
- About Setting Preview Levels for the ECAD Assembly ...............................67
- To Redefine and Suppress Failing Objects During Assembly Update ..........68
- About Cross-Highlighting Selected Objects ..............................................69
- To Cross-Highlight Selected Object Data Across Applications ..................70
- Controlling Import - Export with the ecad_hint.map File ............................72
- About the ecad_hint.map File ....................................................................72
- To Create the ecad_hint.map File ...............................................................72
- Using the ecad_hint.add File .....................................................................72
- Using the ECAD_ALT_NAME .....................................................................73
- Map File Standard Conventions and Examples ..........................................74
- To Reference Custom Parts During ECAD Import .......................................75
- To Control Automatic Layer Assignment .................................................75
- To Change the Other Outline String for Import .........................................75
- To Change the Reference Designator String for Import .............................75
- To Exclude Parts From Import or Export ...................................................76
# Table of Contents

Intermediate Data Format (IDF) ................................................................................. 76
  About the Intermediate Data Format (IDF) .......................................................... 76
  About IDF File Sections ....................................................................................... 76
Supported ECAD File Formats .................................................................................. 78
  About Supported ECAD File Formats ................................................................. 78
Accessing Legacy File Formats ................................................................................. 79
  About Accessing Legacy Formats ....................................................................... 79
  About Using the Allegro Format ......................................................................... 79
  About Using the Dazix Format ........................................................................... 81
  About Using the Visula Format .......................................................................... 81
Glossary ..................................................................................................................... 82
  Glossary for ECAD .............................................................................................. 82
Index .......................................................................................................................... 87
ECAD

Pro/ENGINEER ECAD Overview

The ECAD Help describes how you can import data for printed circuit boards and their components into a Pro/ENGINEER assembly and use ECAD to create 3D models from the imported component outlines. The ECAD Help also discusses how to create assemblies using the 3D models you have created, parametrically design the board outlines, and export the assemblies as board outlines. Refer to these topics for information on using the ECAD user interface, configuring Pro/ENGINEER for ECAD, and performing specific tasks in the ECAD environment.

Tasks for ECAD

<table>
<thead>
<tr>
<th>Establishing a Design Process</th>
<th>Fixing Data Exchange Problems</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suggesting a Design Sequence</td>
<td>Controlling Import Export with ecad_hint.map</td>
</tr>
<tr>
<td>Using ECAD in the Design Process</td>
<td>Using Model and Feature Parameters</td>
</tr>
<tr>
<td></td>
<td>Configuring ECAD</td>
</tr>
</tbody>
</table>

Importing and Exporting ECAD Data

<table>
<thead>
<tr>
<th>Importing Data for Printed Circuit Boards</th>
<th>Handling Holes on Board Outlines</th>
</tr>
</thead>
<tbody>
<tr>
<td>Importing Three-dimensional IC Designs</td>
<td>Using Layers and Coordinate Systems</td>
</tr>
<tr>
<td>Exporting Board Outlines and Component Data</td>
<td></td>
</tr>
<tr>
<td>Using IDF for Data Exchange</td>
<td></td>
</tr>
<tr>
<td>Using Other ECAD File Formats</td>
<td></td>
</tr>
</tbody>
</table>

Working in the ECAD-MCAD Collaboration Mode

<table>
<thead>
<tr>
<th>Performing Collaborative Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comparing Assembly Designs</td>
</tr>
<tr>
<td>Capturing and Analyzing Comparison Results</td>
</tr>
<tr>
<td>Updating Assemblies with Incremental Changes</td>
</tr>
<tr>
<td>Cross-Highlighting Design Objects</td>
</tr>
<tr>
<td>Achieving Design Synchronization</td>
</tr>
</tbody>
</table>
Using Pro/ENGINEER ECAD

About Pro/ENGINEER ECAD in the Design Process

Pro/ENGINEER ECAD lets you import data for printed circuit boards and PCB components into a Pro/ENGINEER assembly. After importing, you can view the board and parts in a 3D context, for example, the PCB within the metal case that contains it.

Alternatively, the board outline dimensions can be established in Pro/ENGINEER, based on the case assembly, and exported for parts placement and routing in Pro/ENGINEER ECAD.

With Pro/ENGINEER ECAD, you can edit certain physical aspects of the board, for example, component positions, keepout areas or mounting holes, and export the edited board back to the original ECAD package.

You can also:

- Use custom-designed component models, based on part outlines imported from your Pro/ENGINEER ECAD library, that represent the 3D shape of components more accurately.
- Use Pro/ENGINEER Assembly commands (or information from the ECAD package) to pre-place certain critical components.

**Note:** Pro/ENGINEER does not import trace or connectivity data from Pro/ENGINEER ECAD. It deals with the three-dimensional shape and placement of components only.
ECAD-MCAD Collaboration

The ECAD-MCAD collaboration mode is available in the standard assembly mode of Pro/ENGINEER. It provides the collaborative environment for Pro/ENGINEER and InterComm Expert. Pro/ENGINEER and ECAD users can propose and share design changes in this collaborative environment.

To initiate the collaboration effort from Pro/ENGINEER, with an ECAD assembly open in Pro/ENGINEER, you must click **Applications > ECAD Collaboration.**

Suggested Design Sequence

To best integrate Pro/ENGINEER with the ECAD design process, use a sequence like this:

1. **Create 3D parametric models of components** - Import each component outline that you will use from the ECAD system library into Pro/ENGINEER, and use it as a basis to create a more detailed 3D model as a part file. When you import the board outline and placement information into an assembly, you can substitute these parts for those that would automatically be created on import.

2. **Parametrically design the board outline** - (complete with cuts, mounting holes, and keepin and keepout areas) as a part file. You can also define keepin or keepout areas for export to the PCB designer.

3. **Create an assembly and place the board part into it** - Using the 3D component models, place parts whose placement should be determined by heat or physical obstruction considerations.

4. **Export the assembly as board outline and component placement information** - The keepin and keepout outlines are also exported with this information. For export, select one of the available ECAD formats.

When the PCB designer has completed placement, you can import all component placement information into Pro/ENGINEER to check for interference between components and other physical obstructions in the assembly.

Use Pro/ENGINEER to make any necessary component placement corrections. Export the board back to the PCB designer to demonstrate the new placement.

Finally, perform a final mechanical analysis of the completed board in Pro/ENGINEER.

**Note:** The transfer of electrical routing information on the board is not supported by the IDF standard at this time.

About Setting Defaults for Faster Import

Click **Tools > Options** and use the **Options** dialog box to set defaults for the import process. When you set these defaults, you are not prompted for values each time a part is imported.

**Component height** - Ideally, the ECAD system specifies component height in its part information. If it does not, then when you import components through ECAD, you can use the **ecad_default_comp_height** configuration option to assign a
default height to components with a zero height value in the interface file. The value for the option should be the value of the default height and its corresponding units.

**Coordinate system names** - When the board and components are imported, a csys is created at the origin of each part that is created. Use the `ecad_board_csys_def_name` and `ecad_comp_csys_def_name` configuration options to assign a default csys name to each object type.

**Default part and assembly templates** - During import, you are prompted to choose a template for the imported part or assembly. You can specify a default template using the `template_ecadpart` and `template_ecadasm` configuration options.

**ecad_hint.map file default location** - You can use the `ecad_mapping_file <path>` configuration option to set a default location for the `ecad_hint.map` file.

**Import parts to automatically created layers** - When the Preferences option `ecad_comp_layer_map` is set to YES, the import routine creates a new layer for each component name and places each newly created reference designator on the appropriate layer.

---

**About Fixing Import Problems in Sketcher**

When you import parts created in an ECAD (2D) system into Pro/ENGINEER, they may contain bad contours caused by open or self-intersecting loops.

To correct the import file, for IDF versions 2.0 and 3.0, select **Edit outline in Sketcher** in the **ECAD Input - Board** dialog box. For the Allegro, Dazix, and Visula file formats, you must select **Yes** against **Edit in Sketcher** in the **ECAD - Import** dialog box or **Sketcher Fix** in the **Import ECAD Library File** dialog box. If the ECAD import process is unable to create a contour for a board outline, the following message appears:

```
Do you want to correct <file name> part geometry with Sketcher? [Yes]
```

You can either abort the import or enter the Sketcher mode to fix the problem. In the Sketcher mode, you can see the imported profile geometry. The sketcher regeneration process ensures correct creation (regenerated or nonregenerated section).

You can create dimensions on the section. All tools in Sketcher are available to correct any problem, for example, to trim corners.

After you have corrected the problems in Sketcher, Pro/ENGINEER continues the import and automatic creation of the feature. The following is written to the `ecad.log` file:

```
If you plan to import this component again, you should export it and then insert the corrected outline as a replacement for the problem outline in the import files.
```

**Note:** If the outline is corrected on import, it is not automatically corrected in the ecad library file. Export the corrected component separately and use the outline to update the `.emp` file to avoid having to correct the same profile repeatedly.
**Tip: The ECAD Log File**

ECAD interface routines write commentaries, warnings, and error messages to a file named ecad.log in your current working directory. Read this file each time you use the ECAD interface.

**Tip: The Z-Axis Offset in IDF**

When you use ECAD to import components into Pro/ENGINEER using IDF 2.0, the system places components with a z-axis offset of 0.0. After import, you can modify the z-axis offset of the component’s placement. In IDF 3.0, you can define an offset.

**Tip: Parametric Dimensions in ECAD**

The dimensions of parts created in ECAD and imported by Pro/ENGINEER are not parametric, and you cannot modify them. However, you can go into the Sketcher mode and add dimensions by redefining the part base geometry feature. To maintain maximum flexibility during the design process, you can create your board outlines and components in Pro/ENGINEER.

After you export parts created in Pro/ENGINEER through ECAD, you lose parametric associativity permanently. If you import them back into Pro/ENGINEER later, the outline is not updated.

**Model Parameters**

The following table lists the model parameters along with additional information to determine when and how you can use them.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Optional Value</th>
<th>Valid Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ECAD_OWNER</td>
<td>ECAD</td>
<td>IDF 3.0</td>
<td>Shows the owner of board or other outline.</td>
</tr>
<tr>
<td></td>
<td>MCAD</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>UNOWNED</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ECAD_PART_TYPE</td>
<td>Panel</td>
<td>IDF 2.0 and IDF 3.0</td>
<td>Shows the component type.</td>
</tr>
<tr>
<td></td>
<td>Board</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Electrical</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mechanical</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Other Outline</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ECAD_PART_NAME</td>
<td>any</td>
<td>IDF 2.0 and IDF 3.0</td>
<td>Shows the other outline name.</td>
</tr>
<tr>
<td>ECAD_CAPACITANCE</td>
<td>any</td>
<td>IDF 3.0 only</td>
<td>Capacitance value.</td>
</tr>
<tr>
<td>ECAD_RESISTANCE</td>
<td></td>
<td></td>
<td>Resistance value.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Optional Value</td>
<td>Valid Format</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>----------------</td>
<td>--------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>ECAD_TOLERANCE</td>
<td></td>
<td></td>
<td>Tolerance value.</td>
</tr>
<tr>
<td>ECAD_THETA_JC</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ECAD_POWER</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Feature Parameters**

The following table lists the feature parameters along with additional information to determine when and how you can use them.

**Note:** All hole parameters are automatically created during import only if you import the holes as features. Set the `ecad_import_holes_as_features` configuration option to `yes` to import holes as features.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Optional Value</th>
<th>Valid Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ECAD_OWNER</td>
<td>ECAD MCAD, UNOWNED</td>
<td>IDF 3.0 only</td>
<td>Owner of ECAD area.</td>
</tr>
<tr>
<td>ECAD_HOLE_TYPE</td>
<td>PTH, NPTH, PIN, VIA, MTG, TOOL, OTHER</td>
<td>IDF 2.0 and IDF 3.0</td>
<td>The type of hole feature. (if the hole is not imported as a feature, the parameter is not imported.)</td>
</tr>
<tr>
<td>ECAD_PLATING_STYLE</td>
<td>PTH, NPTH</td>
<td>IDF 3.0 only</td>
<td>Plated through hole, non-plated through hole.</td>
</tr>
<tr>
<td>ECAD_HOLE_OWNER</td>
<td>ECAD MCAD, UNOWNED</td>
<td>IDF 3.0 only</td>
<td>Owner of the hole feature.</td>
</tr>
<tr>
<td>BOARD_SIDE</td>
<td>TOP, BOTTOM, BOTH</td>
<td>ALL (according to the areas)</td>
<td>The side associated with the place region, place keepin, or place keepout ECAD area.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Optional Value</td>
<td>Valid Format</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>----------------</td>
<td>--------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ROUTING_LAYERS</td>
<td>TOP BOTTOM BOTH, ALL</td>
<td>IDF 2.0</td>
<td>Shows which ECAD board routing layers in the electrical system are included in a Pro/ENGINEER routing area ECAD feature. (No actual routing on the board is supported for transfer by IDF standard.)</td>
</tr>
<tr>
<td>ROUTING_LAYERS</td>
<td>TOP BOTTOM BOTH, ALL, INNER</td>
<td>IDF 3.0</td>
<td>Shows which ECAD board routing layers in the electrical system are included in a Pro/ENGINEER routing area ECAD feature. (No actual routing on the board is supported for transfer by IDF standard.)</td>
</tr>
<tr>
<td>COMPONENT_GROUP_NAME</td>
<td>Any</td>
<td>IDF 2.0 and IDF 3.0</td>
<td>Allow adding or keeping a name for place region ECAD area feature.</td>
</tr>
<tr>
<td>ECAD_ASSOCIATED_PART</td>
<td>BOARD NOREFDES</td>
<td>IDF 2.0</td>
<td>In the ECAD system, this is the part to which the Pro/ENGINEER hole feature relates.</td>
</tr>
<tr>
<td>ECAD_ASSOCIATED_PART</td>
<td>BOARD NOREFDES PANEL Reference Designator</td>
<td>IDF 3.0</td>
<td>In the ECAD system, this is the part to which the Pro/ENGINEER hole feature relates.</td>
</tr>
</tbody>
</table>
Component Feature Parameters

This table lists the feature parameters in Assembly mode for components, along with additional information to determine when and how you can use them.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Optional Value</th>
<th>Valid Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ECAD_NAME</td>
<td>Any</td>
<td>ALL</td>
<td>The ECAD system name of the component (becomes the name of the Pro/ENGINEER .prt file.)</td>
</tr>
<tr>
<td>ECAD_ALT_NAME</td>
<td>Any</td>
<td>ALL</td>
<td>The ECAD system alternative name for the component.</td>
</tr>
<tr>
<td>ECAD_REFDES</td>
<td>Reference Designator</td>
<td>Any</td>
<td>The ECAD reference designator for the component.</td>
</tr>
<tr>
<td>ECAD_PART_TYPE</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ECAD_PART_NAME</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ECAD_PLACEMENT_STATUS</td>
<td>FIXED PLACED UNPLACED</td>
<td>IDF 2.0</td>
<td>Shows the placement type of the component.</td>
</tr>
<tr>
<td>ECAD_PLACEMENT_STATUS</td>
<td>PLACED UNPLACED</td>
<td>IDF 3.0</td>
<td>Shows the placement type of the component.</td>
</tr>
</tbody>
</table>

To Perform a Clearance-Interference Check

Click **Analysis > Model > Volume Interference** and use the **Volume Interference** dialog box to run a volume interference check to detect whether an ECAD component interferes with or falls entirely within a closed quilt representing an ECAD keepin or keepout area.
Configuring Pro/ENGINEER ECAD

About Configuring Pro/ENGINEER ECAD

You can set environment options and other global settings by specifying the required settings in a configuration file. To set configuration options, use the Options dialog box.

This help module contains a list of configuration options in alphabetical order. Each option contains the following information:

- Configuration option name.
- Default and available variables or values. The default values are in italics.
- Brief description and notes describing the configuration option.

To Set Pro/ENGINEER ECAD Configuration Options

1. Click Tools > Options. The Options dialog box opens.
2. Click the Show only options loaded from file check box to see currently loaded configuration options or clear to see all configuration options.
3. Select the configuration option from the list or type the configuration option name in the Option box.
4. In the Value box, type or select a value.
   Note: The default value is followed by an asterisk (*).
5. Click Add / Change. The configuration option and its value appear in the list. A green status icon confirms the change.
6. When you finish configuring, click Apply or OK.

**dazix_default_placement_unit**

*micron, mm, thou*

Specifies the units to be used for data imported in Dazix files.

**dazix_export_mounthole**

*yes, no*

- **yes** - Causes the MOUNTHOLE section of a Dazix file to be processed as a mount hole.
- **no** - Causes the MOUNTHOLE section to be processed as a cut.
dazix_z_translation

yes, no
yes - Passes the objects in the .edn files through z translation.

ecad_area_default_import

cosm_area, 3d_volume
Defines how imported ECAD areas are treated.
• cosm_area - Treats imported ECAD areas as cosmetic area features.
• 3d_volume - Imports ECAD areas with z-heights as a 3D enclosed quilt.

ecad_board_csys_def_name

Specifies the default coordinate system name added to an ECAD board being exported or imported. If you do not set this variable, you are prompted for a name.

ecad_comp_csys_def_name

Specifies the default coordinate system name added to an ECAD component being imported or exported. If you do not set this variable, you are prompted for a name. You can use this configuration option to assign a coordinate system name for the export of component outlines to the ECAD EDA (*.eda) format. When not set to the name of any component coordinate system, the component outlines automatically use the component coordinate system with the name, ECAD_DEFAULT.

ecad_comp_layer_map

yes, no
yes - Allows layer mapping for the ECAD component's import into Assembly.

ecad_comp_xsec_def_name

any, none
Allows you to specify the name of a section plane to be used as the default cross-section for the export of component outlines to the ECAD EDA (*.eda) format.
When used with the ecad_comp_csys_def_name configuration option, the component outlines are exported with the component coordinate systems instead of the cross-sections.
**ecad_create_hint_add**

`yes, no`

Assists in the creation of the `ecad_hint.map` file.

*yes* - If required, automatically renames components, each time a library of component outlines is imported into Pro/ENGINEER. This does not create an `ecad_hint.map` file. It controls the creation of the `ecad_hint.add` file.

**ecad_default_comp_height**

Sets the default value and units for an ECAD component that is being imported. Units are inch, mil (1E-3 inches), thou (1E-6 inches), cm, mm, micron (1E-6 meters), and dsu (1E-8 meters). If not set, the units of the current component are used.

**ecad_default_comp_place_status**

`placed, unplaced, fixed, mcad, ecad`

*placed* - Sets default component placement status for export (parameter setting overrides the default).

**ecad_exp_both_two_areas**

`yes, no`

Supports the export of ECAD areas with different "Above Board" and "Below Board" conditions.

* no - Enables you to export ECAD areas with different "Above Board" and "Below Board" conditions.

* yes - Enables you to export both-sided keepin or keepout ECAD areas as two individual areas (top and bottom).

**ecad_export_cuts_as_holes**

`yes, no`

Exports Pro/ENGINEER cuts as holes to ECAD systems.

* yes - Exports cuts in boards or panels as holes to ECAD systems.

* no - Exports cuts as part of the board outline.

**ecad_export_holes_as_cuts**

`yes, no`

* no - Exports Pro/ENGINEER holes as cuts to ECAD systems.
**ecad_import_holes_as_features**

*yes, no*

Controls the import of holes as Pro/ENGINEER hole features or as part of the board outline. Imports sections specified as **DRILLED_HOLE** as through-all holes. Boards created with Pro/ENGINEER drilled holes export with a default value of **NPTH** for the **ECAD_HOLE_TYPE** parameter. Create this feature parameter if a value of **PTH** is needed for IDF versions 2.0 and 3.0.

- **yes** - Imports holes of board outlines from an IDF file as Pro/ENGINEER hole features. The **ECAD Input - Board** dialog box displays the default **Creation Method** option as **Hole Features** for all category of holes.

- **no** - Imports holes of board outlines from an IDF file as part of the board outline. The default **Creation Method** option for all hole categories is **Board Cutouts** in the **ECAD Input - Board** dialog box.

**ecad_import_relative_accuracy**

*0.0012*

Specifies the relative accuracy value used during the import of ECAD files.

**ecad_load_filtered_holes_to_ui**

*yes, no*

Controls the import of **PIN** and **via** holes from board outlines imported as IDF files. This configuration option determines whether to completely filter out the hole types, **PIN** and **via**, or only set their status to **Filter Out** in the **ECAD Input - Board** dialog box. In effect, it controls the behavior of the **ecad_pin_hole_import** and **ecad_via_hole_import** configuration options.

Set **ecad_load_filtered_holes_to_ui** to one of the following values:

- **yes** - Holes of type **PIN** and **via** are listed in the **ECAD Input - Board** dialog box and you can import these hole types.

- **no** - Completely filters out holes of type **PIN** and **via**, especially when **ecad_pin_hole_import** and **ecad_via_hole_import** are set to no. You cannot recover them or import them back into the design. However, when you set **ecad_pin_hole_import** and **ecad_via_hole_import** to **yes**, you can import these hole types as the **ECAD Input - Board** dialog box lists them.

**ecad_mapping_file**

Specifies that the **ecad_hint.map** file is used for ECAD operations.
**ecad_missing_component_status**

`keep_missing, delete_missing`

Sets up the default status for missing components in the Component Investigate dialog box. Using this dialog box, you can keep missing components by default or delete missing components by default.

- `keep_missing` - Missing components are kept by default.
- `delete_missing` - Missing components are deleted by default.

**ecad_outline_holes_exp_method**

`arcs, default`

Specifies how holes placed on board outlines are exported.

**ecad_panel_csys_def_name**

Specifies the default coordinate system name added to an ECAD panel being imported. If you do not set this variable, you are prompted for a name.

**ecad_pin_hole_import**

`no, yes`

Controls the import of holes of type PIN in the IDF 3.0 files.

- `yes` - PIN holes in the IDF 3.0 file are imported.
- `no` - PIN holes in the IDF 3.0 file are not imported. When you set `ecad_pin_hole_import` to `no`, regardless of whether `ecad_import_holes_as_features` is set to `yes` or `no`, `ecad_pin_hole_import` overrides `ecad_import_holes_as_features`.

**ecad_via_hole_import**

`yes, no`

Controls the import of holes of type VIA defined in the IDF 3.0 files.

- `yes` - VIA holes defined in the IDF 3.0 file are imported.
- `no` - VIA holes defined in the IDF 3.0 file are not imported. When you set `ecad_via_hole_import` to `no`, regardless of whether `ecad_import_holes_as_features` is set to `yes` or `no`, `ecad_via_hole_import` overrides `ecad_import_holes_as_features`.
ecad_use_legacy_formats

yes, no

Controls the availability of the ECAD legacy file formats, such as Allegro, Dazix, and Visula, in the **Type** list of the **File Open** and **Save a Copy** dialog boxes.

- **yes** - The Allegro, Dazix, and Visula formats and their file-types are available in the **Type** list of the **File Open** and **Save a Copy** dialog boxes. You can access them for the import and export of ECAD assemblies.

- **no** - The Allegro, Dazix, and Visula formats are not available in the **Type** list of the **File Open** and **Save a Copy** dialog boxes. This is the default.

ecad_other_outl_csys_def_name

Specifies the default coordinate system name for the **OTHER_OUTLINE** section of an IDF 2.0 ECAD component being imported. If you do not set the coordinate system, Pro/ENGINEER uses **ECAD DEFAULT** as the coordinate system name.

mentor_ver_2_0

yes, no

- **yes** - Exports the file in IDF 2.0 format.

- **no** - Exports the file in IDF 1.0 format unless you select IDF 2.0 from the ECAD FORMAT menu.

template_ecadasm

Specifies that the model will be used as the default ECAD assembly template.

template_ecadpart

Specifies that the model will be used as the default ECAD part template.

Importing ECAD Databases

About Importing ECAD Databases

Board Assembly Files and Library Files

The import process requires two reference files, the board file and a library file. The board file describes the board outline, thickness, any keepin or keepout areas, and the placement positions of all the parts. The library file contains the footprint and height information for all parts referenced in the board file.
In the IDF format, the board file has an .emn extension while the library file uses the .emp extension. Proprietary formats from other vendors use their own extensions. During the import, you are prompted for the location of both these files.

**Note:** When importing a panel assembly, specify the board file (IDF *.emn) instead of *.emp when prompted for the library file.

### 3D Integrated Circuit (3DIC) Designs

The three-dimensional Integrated Circuit designs consist of IC layers and IC structures with their geometric objects. Use the OpenAccess (OA) IC database format with its API library to import the designs into Pro/ENGINEER. The OA format stores the IC information on disk and this format is used to communicate IC data between applications.

### Automatic or Partial Assembly on Import

You can import the whole database, including the board, all placed components, and keepin or keepout outlines in an automated sequence that produces a completed board assembly. Alternatively, you can import the board and parts separately and assemble them in the normal way. If you choose the automated sequence, you are prompted for any part library files or default dimensions that are required.

### Automatic Part Creation

When the parts list and placement information are read in, ECAD uses the 2D part outlines it detects to extrude each part into a 3D shape. During the import, if no defaults are specified in your config.pro file, you are prompted for a height or for a coordinate system name for the part being created. Alternatively, you can reference a library of custom-made parts that you have prepared in Pro/ENGINEER that show more detail than a simple extrusion.

As each part is created in 3D and added to the assembly, it is saved as a separate .prt file in the working directory. The original component name, for example, SN74ALS133N, becomes the file name. One .prt file is created for each reference designator. All reference designators appear on the Model Tree.

### Custom Part Substitution

As an alternative to letting Pro/ENGINEER create the parts automatically, you can create a library of more accurately-shaped custom parts and reference it when you import the PCB. You use an ASCII map file named ecad_hint.map to reference the custom parts as substitutes for the automatically created ones.

### Automatic Layer Assignment

When the preferences option, ecad_comp_layer_map, is set to yes, the import routine creates a new layer for each component name and places each newly created reference designator on the appropriate layer.
ECAD - Help Topic Collection

If you are referencing an `ecad_hint.map` file, you can add lines to the file to direct layer creation and part-layer assignment.

**Additional Supported Objects for Import-Export**

In addition to the board and electrical components, ECAD also imports and exports the following objects in accordance with the IDF 3.0 specification:

- **Panel Outline** - The manufacturing step-and-repeat panel and boards mounted on it. The panel outline is described in an optional separate panel file which can reference one or more board assemblies described in separate files. Any component placed on the panel itself is referenced in a library file.

- **Other Outline** - Extruded shapes of nonelectrical parts that would not have a reference designator, such as a heat sink.

- **Holes** - Drilled holes

- **Keepin and Keepout areas** - Separate outlines can show where to place or prohibit parts, routing, or vias.

For complete information on the IDF import file conventions, see the Intermediate Format Specification Version 3.0.

**Using Automatic Layer Assignment**

When the `ecad_comp_layer_map` preferences option is set to `yes`, the import routine creates a new layer for each component name and places each newly created reference designator on the appropriate layer.

If you are referencing an `ecad_hint.map` file, you can add lines to the file to direct layer creation and part-layer assignment.

New layers are named after the component name, or for `.map` file references, the mapped name. The syntax is `ECAD_<comp name or mapped name>`.

If no `ecad_hint.map` file exists, ECAD automatically creates a separate layer for each component type that is imported and places the component or components on that layer. Components with the same name are placed on the same layer.

<table>
<thead>
<tr>
<th>Automatic Layer Assignment Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>*<em>For a <em>.emn file containing the following placement record:</em></em></td>
</tr>
<tr>
<td><strong>PLACEMENT</strong></td>
</tr>
<tr>
<td>CC1206-1 151K41000S C1</td>
</tr>
<tr>
<td>1200.00000 1550.00000 90.00000 TOP PLACED</td>
</tr>
<tr>
<td>CC1206-2 151K31001S C2</td>
</tr>
<tr>
<td>1200.00000 550.00000 90.00000 TOP PLACED</td>
</tr>
<tr>
<td>CC1206 151K41000S CC1</td>
</tr>
<tr>
<td>1900.00000 1000.00000 90.00000 BOTTOM PLACED</td>
</tr>
<tr>
<td>RC1206 161F21050S RR1</td>
</tr>
<tr>
<td>1200.00000 1000.00000 270.00000 BOTTOM PLACED</td>
</tr>
</tbody>
</table>
This layer configuration is produced:

<table>
<thead>
<tr>
<th>Layer Name</th>
<th>Components on this layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>ECAD_CC1206-1</td>
<td>CC1206-1</td>
</tr>
<tr>
<td>ECAD_CC1206-2</td>
<td>CC1206-2</td>
</tr>
<tr>
<td>ECAD_CC1206</td>
<td>CC1206</td>
</tr>
<tr>
<td>ECAD_RC1206R</td>
<td>C1206</td>
</tr>
<tr>
<td>ECAD_SO14</td>
<td>SO14 (u1, u2, uu1)</td>
</tr>
</tbody>
</table>

**Using the ecad_hint.map File**

Using the `ecad_hint.map` file, you can specify an overriding mapping (over the automatic mapping) to produce a new `ECAD_<mapped name>` layer. The component is placed in that layer.

```
map_objects_by_name->
ECAD_NAME "eesmb"
ECAD_ALT_NAME "DM7442N"
ECAD_TYPE ""
MCAD_NAME "EESMB_DM7442N"
MCAD_TYPE "part"
MCAD_LAYER "<ANY>"
END
```

**Using Coordinate Systems**

If you create your own component models, you must provide each one with a coordinate system that represents the part origin to the ECAD package, and that includes the height dimension along the z-axis. If you are creating the component as a custom part in Pro/ENGINEER, start the part by placing the (0,0,0) of the coordinate system at the intersection of the three default datum planes.

As ECAD places components by locating component coordinate systems in relation to the board coordinate system, the coordinate system orientation you use for placement on the ECAD outline should match that of the custom Pro/ENGINEER part.
If the replacement is an assembly, an assembly coordinate system must be present. Incorrect orientation results in incorrect placement of the replacement component.

The illustration below shows a custom part, created in Pro/ENGINEER, representing a DIP16 with the csys `ECAD_DEFAULT` located at the part origin (usually pin 1).

In IDF 3.0, the components can be placed using the **Mate Offset** assembly option. For all other formats, the system mates the components to the board.

You can create a section plane for the component outline as a cross section, or select a planar surface for the component outline. The section plane is used as the footprint of the extents of the part and must be parallel to the xy-plane of the placement coordinate system. You are prompted to identify the section plane as part of the export procedure.

Orient the component so that the z-axis of its chosen coordinate system points in the direction normal to the surface of the board, away from the surface:

- If you place a component on the top surface of the board, the direction of the z-axis of the component’s coordinate system points in the same direction as the z-axis of the board’s coordinate system.
- If you place a component on the bottom surface of the board, its z-axis points in the opposite direction from the board’s z-axis.

You should know how the default component coordinate systems on the parts in your ECAD package are positioned.
Top and Bottom Side

Pro/ENGINEER uses the coordinate system to distinguish between top and bottom surfaces:

- The z-axis of the coordinate system of the board should be normal to the top and bottom planes.
- The positive z-axis should point from the bottom plane to the top plane.

You can select or create any coordinate system where the z-axis is normal to the top and bottom planes and the origin is located on either the top or the bottom surface of the board part.

Note:

- Pro/ENGINEER does not support left-handed coordinate systems. If used, component placement will not be as expected.
- As the direction of the z-axis is normal to the top and bottom, and also points toward the top, the bottom and top can be different sides of the same surface.
- When importing or exporting information that depends on the identification of the top and bottom surfaces of the board, the system checks to see if two parallel planes are normal to the z-axis. If so, it designates these the top and bottom based on the direction of the z-axis.
- If more than two planes are normal to the z-axis, the system prompts you to select a top and a bottom. The bottom surface can be a surface or datum. The top can be:
  - A surface or datum (if importing)
  - A surface or datum with a cross-section on it (if exporting)

Naming Default Coordinate Systems

During import or export, when ECAD needs a coordinate system, it first searches for a default coordinate system. ECAD automatically looks for a coordinate system with the default name, ECAD_DEFAULT. ECAD prompts you if it cannot find one, or if you have not specified another default name.

To specify a default name of your own, set these configuration options:

- `ecad_board_csys_def_name` - Establishes a default name for the board’s coordinate system.
- `ecad_comp_csys_def_name` - Establishes a default name for the coordinate systems that components use.

If a default coordinate system exists, Pro/ENGINEER uses it automatically, without requesting any additional information about coordinate systems. If you use the default coordinate system name for all components, you can assemble all necessary components to the board without specifying any additional component placement information.
The part’s outline is imported as an extruded section to create a Pro/ENGINEER part when you either place the component for the first time, or when you import it separately as a new part. The default coordinate system is located on the plane of the extruded section, and the z-axis is parallel to the direction of the extrusion.

**To Import a PCB or Panel Assembly**

To import the whole assembly from either a board or a panel file:

1. Click File > Open. The File Open dialog box opens.
2. Select the ECAD board or panel file.
3. Click Open. The Import New Model dialog box opens.
4. Under Type, select Assembly.
5. Click Include ECAD Import Dialog and click OK. If the file you have selected is an IDF 3.0 or 2.0 file, the ECAD Input - Board dialog box opens. The ECAD - Import dialog box opens if the file selected for import is of the type Allegro, Dazix, or Visula.
6. Click Yes for Edit in Sketcher if you want to edit the board in Sketcher.
7. Clear the Use Default Template check box to select a template from available templates. This check box is selected by default. A new assembly is created with the board as the first part. If you reference a panel file, then the assembly is created with the panel as the first part.

   If the board data contains drilled hole information, under Options, the Hole Import list displays the hole information. By default, all hole types except PIN are selected.
8. Click the PIN check box, if required.
9. If required, click Open Log Window for more information on the import operation.
10. Click OK. The PCB components are imported and assembled in the board or the panel.

**To Import a Board Outline**

Use this procedure to import a board, with holes and keepin or keepout areas, but without the components, as a Pro/ENGINEER part.

1. Click File > Open. The File Open dialog box opens.
2. Select an ECAD package from the Type list.
3. Select the ECAD board outline file that you want to import from the list of available files.
4. Click Open. The Import New Model dialog box opens. Under Type, the Part check box is selected by default.
5. Accept the default name or type a name for the new part in the Name box.

6. Click OK. The ECAD - Import dialog box opens if the file selected for import is of the type Allegro, Dazix, or Visula. If the file you have selected is an IDF 3.0 or 2.0 file, the ECAD Input - Board dialog box opens.

   **Note:** The Hole handling options in the ECAD Input - Board dialog box are available only for board outlines saved to IDF versions 2.0 and 3.0. These options allow you to selectively import or filter holes based on their categories, their association with the board part or components, and their diameters.

   The Import List in the ECAD - Import dialog box shows only one part type, that is, the board with its name and height, though the import file contains data of the board and all parts. The List Item Settings text boxes of Part Name and Height also display the name and height of the board.

   Import the board as a part and create an assembly using this board as the base part. You can then import the other components into the assembly.

7. Click Yes for Edit in Sketcher in the ECAD - Import dialog box if you want to edit the board in Sketcher.

8. Clear the Use Default Template check box to select a template from available templates. This check box is selected by default. A new part is created with the board as the first part. If you reference a panel file, then the part is created with the panel as the first part.

   If the board contains drilled hole information, the Hole Import list under Options displays the holes information. By default, all hole types except PIN are selected.

9. Click the PIN check box, if required.

10. If required, click Open Log Window for more information on the import operation.

11. Click OK. The data is imported and converted to a Pro/ENGINEER part.

    o A coordinate system is created at the ECAD_DEFAULT origin.

    o The z-axis direction is bottom to top.

   Use the ecad_board_csys_def_name configuration option to specify a default name for the board coordinate system. Create an assembly with this part. Use File > Open to add the parts from the same input file.
The following illustration shows the ECAD_DEFAULT coordinate system with (0,0,0) at the bottom of the board. The z-positive direction is bottom to top.

Note: An ECAD import, unless performed through Sketcher Fix, produces sections without dimensions (nonregenerated sections).

To Import a Panel Outline

Note: Only IDF 3.0 supports panel import.

1. Click File > Open. The File Open dialog box opens.

2. Select an ECAD package from the Type list.

3. Select the ECAD panel file that you want to import from the list of available files and click Open. The Import New Model dialog box opens. Under Type, the Part check box is selected by default.

4. Accept the default name or type a name for the new part in the Name box.

5. Click OK. The ECAD Input - Board dialog box opens. The Import List shows only one part, that is, the panel.

6. Click Edit outline in Sketcher to edit the board in Sketcher. You are returned to ECAD from the Sketcher mode when you complete modifying the board outline.

7. Clear the Use Default Template check box to select a template from available templates. This check box is selected by default. A new part is created in which the board is imported as the first part. If you reference a panel file, the panel is imported as the first part.

8. If required, click Open Log Window for more information on the import operation.
9. Click **OK**. The panel is imported and converted to a Pro/ENGINEER part.
   - A coordinate system is created at the **ECAD_DEFAULT** origin.
   - The z-axis direction is bottom to top.

   **Note:** Use the **ecad_board_csys_def_name** configuration option to specify a default name for the coordinate system of the board.

**To Import Components as Parts**

Use this procedure to create a file with a **.prt** extension for a single component or to bring such files for all components into a session.

1. Click **File > Open**. The **File Open** dialog box opens.

2. Select an ECAD Library package from the **Type** list, click the ECAD file that you want to import from the list of available files, and click **OK**. A new part file opens. The **Import ECAD Library File** dialog box also opens.

3. For the **Import Type**, select **All Components** or **Component**. If you select **Component**, you can select **Sketcher Fix** to open the part outline in Sketcher. You must know the name of the part as it appears in the import file to specify it in the **Component Name** box. Otherwise, the part is automatically extruded.

4. Clear the **Use Default Template** check box to select a template from available templates. This check box is selected by default.

5. If required, click **Open Log Window** for more information about the import operation.

6. Click **OK**.

   - If you selected a single component, then the component is displayed as a file with a **.prt** extension.
   - If you selected **All Components**, the **.prt** files are stored in session, but not stored on disk or displayed. Use **File > Open** and select **In Session** to select the file or files to work on.
   - A coordinate system named **ECAD_DEFAULT** is created at the part origin. The z-axis direction is bottom to top.

   **Note:** Use the **ecad_comp_csys_def_name** configuration option to specify a default name for the coordinate system of the board.

**To Import Components Into an Assembly**

Use this procedure to import ECAD components after the PCB outline has been imported or created and opened as the base part of an assembly.

1. In an assembly file, click **Insert > Shared Data > From File**. The **Open** dialog box opens.
2. Select **ECAD IDF *.emn** as the required package from the **Type** list, and choose the ECAD file that you want to import from the list of available files.

   To import Allegro, Dazix, or Visula files, you must set the `ecad_use_legacy_formats` configuration option to `yes`. The Allegro, Dazix, and Visula file formats are not available in the **Type** list of the **File Open** dialog box because the `ecad_use_legacy_formats` configuration option is set to `no`, by default.

3. Click **Open**. The **ECAD Input – Assembly** dialog box opens with the following options:

   - **Board Reference Coordinate System** - Displays the value of the `ecad_board_csys_def_name` configuration option.
   - **Component List** - If all the components are in session, then the components are listed in the **Component List. Component List** displays the following information:
     
     - **Insert** - Displays the insert status of the listed component. You can change the insert status of the component to **Yes** or **No**.
     - **Component Name** - Lists the component name.
     - **Ref. Des.** - Lists the unique designation of each component in the ECAD assembly. If one component is assembled multiple times, then each instance of the assembled component has a different reference designator.
     - **Get From** - Shows whether the component is a new component or is present in the session or the search path. If the component is present in the session or the search path, the **Get From** list displays the status as **Exist**. If the component is a new component, then the **Get From** list displays the status as **New**.
     - **Coordinate System** - In case of a new component, Pro/ENGINEER uses the default coordinate system that cannot be changed. When you create a new component, Pro/ENGINEER uses either the default coordinate system or the one specified by the `ecad_comp_csys_def_name` configuration option.
   - **Other Outlines List** - **Component Name** lists the other outlines.
     
     Select the required other outline and change its **Insert** status to **Yes** or **No** as required. You can import the `.OTHER_OUTLINE` sections from the IDF file only. Other outlines are volumes representing non-electrical items that would not have reference designators.
   - **Library File for New Components** - If required, select a library file by clicking **Browse** and selecting the required file. **Library File for New Components** is not available if all components are in session or in the search path.
   - **Investigate Placement** - Imports placements in Investigate mode. This option lets you selectively accept or reject the placements of new or changed components.
o **Investigate Geometry** - You must click **Investigate Placement** to use the option **Investigate Geometry**.

o **Use Default Template** - Click **Use Default Template** to use the default template for importing the components into the assembly. **Use Default Template** is not available if all the components that are being imported into the assembly are present in the session or the search path.

o **Open Log Window** - Click **Open Log Window** for more information on the import operation.

4. Click **OK**. The **Open** dialog box opens. The **Type** box displays a list of library formats for the ECAD file that you are importing. Select the required library format.

   **Note:** The **Open** dialog box opens if the library file is not set in the **Library File for New Components** collector present in the **ECAD Input – Assembly** dialog box.

5. Click **Open** to open the file and start the import process.

6. If the file you import contains component placement records, use **GET COORD S** or **SEL COORD S** to create or select a coordinate system for each component, unless you have specified a default component coordinate system in the configuration file.

   If you selected **Investigate Placement** and **Investigate Geometry** in the **ECAD Input - Assembly** dialog box, Pro/ENGINEER displays the **Component Investigate** dialog box that lists all the changed, missing and new components.

   Saving the assembly also saves component placement information when both the component outlines and the placement information are present. If only one is present, you must retrieve each component separately and save it later when you retrieve the assembly.

   Pro/ENGINEER imports the components. If it also imports placement information, Pro/ENGINEER automatically places the components on the board.

**To Substitute Custom Pro/ENGINEER Parts**

To import using custom Pro/ENGINEER parts, place the name of the replacement Pro/ENGINEER component in the **mcad_name** section of the **ecad_hint.map** file.

- If changes are necessary during import, the system specifies any additions in a file named **ecad_hint.add**.

- Specify both **ECAD_NAME** and **ECAD_ALT_NAME** when replacing components with **ecad_hint.map**.

**To Import a Non-Electrical Volume**

An other outline is an extruded footprint that represents a solid part, such as a heatsink, that would not have a reference designator. It is used only in the IDF 2.0 and 3.0 transfer formats.
To import another outline volume into an assembly:

1. Click **Insert > Shared Data > From File**. The **Open** dialog box opens.
2. Select the .emn file or file with Other Outline information and click **Open**. The **ECAD Input - Assembly** dialog box opens. The **Board Reference Coordinate System** displays the value of the **ecad_board_csys_def_name** configuration option.
3. If all the components are in session then the components are listed in the **Component list**. The **Component list** lists the insert status, component name, and coordinate system. In case of a new component, Pro/ENGINEER uses the default coordinate system that cannot be changed. When you create the component, Pro/ENGINEER either uses the default coordinate system or the one specified by the **ecad_comp_csys_def_name** configuration option.
4. Select the **Other Outline** and change its **Insert** status to **yes** or **no** as required. By default it is set to **no**.
5. You can select a library file if required by clicking **Browse** in **Library File for New Components**, and selecting the required file. This option is not available if all components are in session.
6. You can investigate the placement, or geometry by clicking **Investigate Placement** and **Investigate Geometry**.
7. Click the **Use Default Template** to use the default template for importing the other outline volume into the assembly.
8. If required, click **Open Log Window** for more information on the import operation.
9. Click **OK**. You are prompted to select a coordinate system. When you specify a coordinate system, the other outline volume is assembled to the board.

**To Specify Parts as Electrical or Mechanical**

1. In a part file, click **Tools > Parameters**. The **Parameters** dialog box opens.
2. Click and create a string parameter, **ECAD_PART_TYPE**, with a value of either **ELECTRICAL** (electrical component) or **MECHANICAL** (mechanical component).
   
   If no parameter is defined, the part is mechanical by default.

**To Show or Hide Reference Designators**

You can show or hide reference designators using the **Environment** dialog box.

1. Click **Tools > Environment**. The **Environment** dialog box opens.
2. Check the **Reference Designators** box to display the reference designators in the model.
3. Click **OK**.
To Assign or Rename a Reference Designator

Use this procedure to assign a reference designator to components that you design and position with Pro/ENGINEER.

1. In **Assembly** mode, click **Edit > Setup > Name > Component**.
2. Select the component whose name you want to change.
3. At the prompt, type a new name.
4. Click the check box next to the prompt. The name of the reference designator is changed to the one you specify.

You can also assign or rename a reference designator using the Model Tree.

1. Click **Settings > Tree Columns**. The **Model Tree Columns** dialog box opens.
2. In the **Type** box, select **ECAD Params**.
3. Click **ECAD_REF_DES** from the list of available columns, then **>>** to move the selected column to the **Displayed** list.
4. Click **OK**. The reference designators appear in a column associated with each part in the Model Tree. Assign or rename the reference designator of a part by clicking the cell adjacent to the part.

When the system exports the component from the assembly, it passes on the new name to the receiving ECAD system.

**Note:**
- If you do not specify a reference designator for a new component that was placed in Pro/ENGINEER, and you use IDF to export the assembly, the neutral file uses the **NONAME** tag as the reference designator for that component. When you import the same neutral file back into Pro/ENGINEER, it does not recognize the component as the original. Instead, it uses the information in the neutral file to place a new component in the assembly. As you have not specified one, the reference designator for this new component is not present.
- You can rename a reference designator in **Assembly** mode but you cannot remove the text note entirely.

To Manipulate a Reference Designator

You can manipulate reference designators in:
- The **Assembly** mode
- The **Drawing** mode

In the Assembly Mode

1. Open the **Note** dialog box by doing one of the following:
   - From the **ASSEMBLY** menu, click **Edit > Setup > Notes > Modify**.
Right-click a reference designator note in the Model Tree and then click **Properties** from the shortcut menu.

Select a reference designator in the graphics screen, click the right mouse button and then click **Properties** from the shortcut menu.

2. Under **Name**, you can view the reference designator name.

3. Under **Style**, choose the text style.

4. Under **Placement**, click **Move** to change the location of the reference designator.

5. Click **OK**.

**Note:** You cannot modify the text of the reference designator.

You can also use the model tree to manipulate reference designators:

1. Click **Settings > Tree Filters**. The **Model Tree Items** dialog box appears.

2. Check **Notes** and click **OK**. Reference designators are displayed in the model tree just as 3D notes but with a different icon for identification.

3. Select a reference designator note in the Model Tree.

4. Right-click and select one of the following options and make the necessary changes:
   - **Add Link**
   - **Move**
   - **Erase**
   - **Text Style**
   - **Properties**
   - **Info**

Refer to LEGACY help for more information on these options. The **Add Link**, **Move**, **Erase**, **Text Style**, **Properties**, and **Info** options are also available when you select a reference designator in the graphics window and right-click.

**In the Drawing Mode**

1. Click **View > Show and Erase** and then select the ECAD object, to display the reference designators of the object in the drawing.

2. Select a reference designator note.

3. Right-click and select one of the following and make the necessary changes:
   - **Erase**
   - **Edit Attachment**
   - **Move Item to View**
- Insert Jog
- Arrow Style
- Save Note
- Move Special
- Properties
- Add Hyperlink

Refer to the help on LEGACY for more information on these options.

**Note:** Insert Jog, Arrow Style and Edit Attachment are available on the menu if a leader is added to the reference designator note.

**To Import Using Investigate Mode**

**In Assembly Mode**

You can use the Investigate mode to examine final component placement before you complete the import procedure. In the Investigate mode, you can accept or reject the placement of an existing component that is modified into your assembly.

In the **ECAD Input - Assembly** dialog box, you can:

- Select **Investigate Placement**, only if you have selected an ECAD IDF format as your import format.
- Select **Investigate Geometry** only if you have selected **Investigate Placement** in the **ECAD Input - Assembly** dialog box.
- You can check the results of the import by selecting **Open Log Window**.

In the investigate placement mode, component placement in the imported file is compared with its previous placement. Components with reference designators that did not exist in the assembly earlier are treated as new components. Each of these new or changed components is imported and displayed in Pro/ENGINEER as a working component, and the **Component Investigate** dialog box opens.

**Note:** Pro/ENGINEER compares two components for placement changes only if they have the same reference designator. Therefore, if a reference designator has changed, any change in its placement is not detected, and the component is treated as if it were a new component in the imported file.

The **Component Investigate** dialog box lists the reference designators of all components that are new, changed, or missing in the assembly along with the Pro/ENGINEER model name and its status. The status of each component is one of the following:

- **Replace** - The placement of this component is replaced with the new component placement from the file being imported.
- **Keep** - The placement of this component overrides any new component placement in the file being imported.
• **Accept New** - This new component is placed in the imported assembly.

• **Reject New** - This new component is not placed in the imported assembly.

• **Keep Missing** - This component is missing in the imported file, but is kept in the assembly.

• **Delete Missing** - This component is missing in the imported file and is deleted in the assembly.

**Status Color Descriptions**

- **Replace** status appears in blue showing the new position.

- **Accept New** status appears in magenta.

- **Keep Missing** components appear in green.

By default, all changed components are replaced and all new components are accepted.

The `ecad_missing_component_status` configuration option enables you to keep missing components or delete missing components by default, in the **Component Investigate** dialog box. Use the `keep_missing` configuration option to keep missing components by default.

Filter the components displayed in the **Component Investigate** dialog box to display only new components, changed components, or both, by selecting from the list at the bottom of the dialog box. The default is to display both new and changed components. If you select a component in the list, it is highlighted in the assembly.

To change the status of a component, select the component in the dialog box and then click **Change Status** to switch between **Replace** and **Keep** for changed components or **Accept New** and **Reject New** for new components.

To preview any changes you make to the new or modified components, click **Preview**. The new or modified components change according to the specifications in the dialog box.

When you finish making changes to the status of the component placements, click **OK** to complete the import.

**In Part Mode**

1. Click **Insert > Shared Data > From File**. The **Open** dialog box opens.

2. Click the required ECAD package from the **Type** list, and select the ECAD file that you want to import from the list of available files. The **Ecad - Import** dialog box opens.

   **Note:** The **Ecad - Import** dialog box opens only if you have inserted shared data from a file.

3. Click **Yes** to activate the **Investigate Geometry** option in the **Ecad - Import** dialog box.
4. Click OK. The **Board Geometry Investigate** dialog box opens. The feature identified for the geometry update is displayed under **Feature Type** and its status is displayed under **Status**.

5. In the **Filter** box, select one of the following:
   - **All** - To select the entire part
   - **Part Section** - To select board outlines
   - **Area Features** - To select keepin and keepout areas

   Depending on your selection in the **Filter** list, the relevant feature is displayed under **Feature Type**.

7. To change the status of a feature type, select the feature type in the dialog box and click **Change Status** to switch between Replace and Keep.

8. If required, click **Open Log Window** for more information on the import operation.

9. Click OK to complete the import.

### Selective Import of Holes

**About the Selective Import of Holes from Board Outlines**

You can use the Hole handling options in the **ECAD Input - Board** dialog box to selectively import or filter out holes based on their categories while importing board geometry.

The various hole categories are as follows:

- **Type** - Holes based on their association with the board outline or use, such as, **PIN**, **VIA**, **MTG**, **TOOL**, and user-defined holes.

- **The associated part** - Holes based on the associated part components. The board can be the associated part.

- **The hole-type and the associated part** - Hole types **PIN**, **VIA**, **MTG**, **TOOL**, and **Other**, with their associated parts or components. For example, **PIN_BOARD** is a hole of type **PIN** with the board as its associated part.

- **The diameter** - Holes grouped according to their diameters.

You can import the selected category of holes as the following features:

- **Hole features** - Individual, standard holes.

- **Cut features** - Holes of a specific category are grouped into a single cut with a non-generated section. The holes of a group are collectively a cut extrude. The cut features are defined from the top surface of the board with a "through all" depth option. They reference the top and front datum planes of the board. Hole parameters, such as **ECAD_OWNER**, **ECAD_PLATING_STYLE**, **ECAD_ASSOCIATED_PART**, and **ECAD_HOLE_TYPE**, are retained as parameters of the cut feature.
Part of the board outline - Holes are part of the outline sketch and new features are not created.

Alternatively, you can set filtration rules, based on hole diameters, for the hole categories selected. You can also configure the default settings of the Hole handling options to optimize the import of holes based on priority for board outlines with a large number of holes.

Note: The Hole handling options are available in the ECAD Input - Board dialog box only when importing board outlines saved to IDF versions 2.0 and 3.0. They are not available for outlines other than board.

To Selectively Import Holes While Importing a Board

1. Click File > Open. The File Open dialog box opens.
2. In Type, select ECAD IDF (*.emn).
4. Click Open. The Import New Model dialog box opens.
5. In Type, retain the default selection of Part or click Assembly and Include ECAD Import Dialog.
6. In Name, accept the default part or assembly name displayed or specify a new name.
7. Click OK. The ECAD Input - Board dialog box opens.
8. Edit the name and height of the board outline in Name and Height, if required.

Note: The Hole handling section is available only when the board outline has holes on it.

9. Select one of the following hole categories from the Handle By list:
   - Type - Groups holes of the following types and order, based on their association and existence on the board outline and use. This is the default hole category.
     - PIN - Holes associated with a pin component.
     - VIA - Holes associated with a via conductive.
     - MTG - Holes used for mounting.
     - TOOL - Holes used for tooling.
     - Other - User-defined holes.
   - Associated Part - Groups holes based on their associated part components.
- **Type & Associated Part** - Groups hole-types of the Type category with their associated parts or components.

- **Diameter** - Groups holes according to their diameters.

The label of the first column of Hole handling dynamically changes according to the hole category selected. # of Holes displays the number of holes of the selected category.

10. Select one of the following import options from Creation Method for a selected hole category or right-click and access these options on the Set Creation Method to menu.

- **Hole Features** - Imports holes as individual standard hole features. This is the default import method for all hole categories.

- **Cut Feature** - Groups and imports holes as a single cut feature.

- **Board Cutouts** - Imports holes as part of the board outline.

- **Filter Out** - Filters out holes of the selected category.

11. Define filtration rules, according to the following label that Filter displays:

- **Defined** - Specifies that filtration rules are defined for the selected hole category.

  Right-click in Hole handling and select Remove Diameter Filter to remove these rules.

- **Not defined** - Specifies that filtration rules are not defined for the selected hole category.

  Right-click in Hole handling, select Add/Modify Diameter Filter, and define filtration rules in the Holes Diameter Filter Out dialog box.

- **N/A** - Specifies that filtration rules are not required for the selected hole category. Diameter selected on the Handle By list or Filter Out selected from Creation Method shows this status.

  **Note:** Add/Modify Diameter Filter is not available when you select Diameter on the Handle By list or Filter Out as the Creation Method.

12. Hold down the SHIFT and CTRL keys to select all rows or CTRL to select multiple rows of the Hole handling table. Right-click and select a Creation Method option for all the selected rows on the Set Creation Method to menu to import or filter out holes.

  **Note:** If a message warns you that holes that exceed the 5000-limit are ignored and prompts you to use configuration options to import specific hole types, click Close in the message window. Use the ecad_pin_hole_import, ecad_via_hole_import, and the ecad_load_filtered_holes_to_ui configuration options to configure the import of PIN and via holes.
13. Click OK. The holes are imported in the order of their listing in the Hole handling table. If you had selected Open Log Window, the log window opens with details such as the type of hole features imported or filtered out.

To Define Rules for the Filtration of Holes by Diameters

1. Click File > Open. The File Open dialog box opens.

2. Import an ECAD IDF (*.emn) file consisting of a board outline with holes. The ECAD Input - Board dialog box opens.

3. Select a hole category from the Handle By: list.
   
   Note: Do not select Diameter in the Handle By list. You cannot set filtration rules for this category.

4. Select an import option for the selected category of holes from Creation Method.
   
   Note: Do not select Filter Out in Creation Method. For Filter Out, Filter displays N/A as the filtration state.

5. If the Filter column displays the state of filtration for the selected hole category as Not defined, right-click in Hole handling, and select Add/Modify Diameter Filter. The Holes Diameter Filter Out dialog box opens.

6. Select one of the following filtration rules from the Condition list in the Define more rules section and specify a value in Hole Diameter:
   
   o Is greater than - Filters out holes with diameters larger than the specified value. This is the default rule.
   
   o Is equal or greater than - Filters out holes with diameters equal to or larger than the specified value.
   
   o Is between - Filters out holes with diameter that are within the specified range. Specify the range of diameter values in the additional text box.
   
   o Is less than - Filters out holes with diameters lesser than the specified value.
   
   o Is equal or less than - Filters out holes with diameters equal to or lesser than the specified value.
   
   o Is equal to - Filters out holes with diameters equal to the specified value.

7. Click Add to list to add the filtration rule with its corresponding value to the Filter Out holes that match these rules list. Save Filter and Remove All are available only when you add a rule to this list.

8. Define one or more filtration rules, individually adding a rule with its corresponding diameter value, to the Filter Out holes that match these rules list. You can set a rule multiple times for different diameter values or use all rules.
The **Filter Out holes that match these rules** list displays the rules and their values as separate rows. You can perform the following additional tasks, if required:

- **Load Filter**: Click Load Filter and use the Open dialog box to load filtration rules that you have predefined in a text file.
- **Save Filter**: Click Save Filter to save the filtration rules in **Filter Out holes that match these rules** to the `rules_list.txt` file located in the working directory.
- **Remove**: Select one or more filtration rules in the **Filter Out holes that match these rules** list and click Remove to remove one or more rules. Remove and **Change** are available only when you select a rule in this list.
- **Remove All**: Click Remove All to remove all the filter rules listed in the **Filter Out holes that match these rules** list.

The **Remove Rules** dialog box prompts you to confirm the deletion of the filter rules when you click **Remove** or **Remove All**.

- **Change**: To change a rule, select it in **Filter Out holes that match these rules**, select another rule from the **Condition** list, change the **Hole Diameter** value if required, and click **Change**.

  **Note**: Change is not available for the multiple selection of filtration rules.

9. Click **OK**. You are returned to the **Ecad Input - Board** dialog box. **Filter in Hole handling** displays **Defined** as the state of filtration for the selected hole category.

10. Click **OK** in the **Ecad Input - Board** dialog box. Holes that match any or all the defined filtration rules are filtered out.

### To Import Other Outlines from the Board

1. Click **File > Open**. The **File Open** dialog box opens.
2. Import an **ECAD IDF (*.emn)** file consisting of other outlines.
3. Click **OK**. The **ECAD Input - Board** dialog box opens.

   The **Input Type** list is available only when the IDF file selected for import consists of other outlines in addition to the board outline. The **Input Type** list displays **Board** as the default with the name and the height of the board outline displayed in **Name** and **Height**.

4. In **Input Type**, select **Other Outline**. The label of the **ECAD Input - Board** dialog box changes to **ECAD Input - Other Outline**. **Name** and **Height** display the names and the heights of the other outline profiles.
5. Select the other outline and edit its name and height in Name and Height, if required.

**Note:** The Hole handling section is not available in the ECAD Input - Other Outline dialog box.

6. Click OK to import the other outline instead of the board from the IDF file.

### Configuring the Selective Import of Holes

You can use the following configuration options, individually or in combination with each other, to configure the hole import options in the ECAD Input - Board dialog box:

- **ecad_import_holes_as_features** - Imports holes as individual standard hole features or as part of the board outline.

- **ecad_pin_hole_import** - Controls the default setting for the import or filter of the PIN type holes.

- **ecad_via_hole_import** - Controls the default setting for the import or filter of the via type holes.

**Note:** The **ecad_import_holes_as_features** configuration option is not affected by the values assigned to **ecad_pin_hole_import** and **ecad_via_hole_import**.

When you use a combination of **ecad_import_holes_as_features** and **ecad_pin_hole_import**, the default settings in the ECAD Input - Board dialog box are as follows:

<table>
<thead>
<tr>
<th><strong>ecad_import_holes_as_features</strong></th>
<th><strong>ecad_pin_hole_import</strong></th>
<th>Default Settings of ECAD Input - Board dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>yes</td>
<td>yes</td>
<td><strong>Creation Method</strong> is <strong>Hole Features</strong> for all hole categories.</td>
</tr>
<tr>
<td>no</td>
<td>no</td>
<td><strong>• Creation Method</strong> is <strong>Board Cutouts</strong> for hole categories selected as <strong>Associated Part</strong> and <strong>Diameter</strong>. <strong>• Creation Method</strong> is <strong>Filter Out</strong> for PIN holes selected as <strong>Type</strong> and <strong>Type &amp; Associated Part</strong>.</td>
</tr>
<tr>
<td><code>ecad_import_holes_as_features</code></td>
<td><code>ecad_pin_hole_import</code></td>
<td>Default Settings of ECAD Input - Board dialog box</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>------------------------</td>
<td>--------------------------------------------------</td>
</tr>
</tbody>
</table>
| yes                             | no                     | • **Creation Method** is **Hole Features** for hole categories selected as **Associated Part** and **Diameter**.  
• **Creation Method** is **Filter Out** for the **PIN** type holes selected as **Type** and **Type & Associated Part**. |
| no                              | yes                    | **Creation Method** is **Board Cutouts** for all hole categories. |

**Note:** The import of **PIN** and **via** holes are not mutually exclusive. A combination of `ecad_import_holes_as_features` and `ecad_via_hole_import` imports or filters out hole type **via**, similar to the results of the combination of `ecad_import_holes_as_features` and `ecad_pin_hole_import` configuration options.

### About Importing Holes According to Priority

When a board outline consists of more than 5000 holes, you can configure the import so that the first 5000 holes imported to Pro/ENGINEER include holes that suit your requirements. Additionally, you can prioritize the import of specific hole types, such as **PIN** and **via**.

**Note:** The default values of the `ecad_pin_hole_import` and `ecad_via_hole_import` configuration options indicate the priority of the hole types, **PIN** and **via**, in Pro/ENGINEER. By default, `ecad_pin_hole_import` is set to **no** while `ecad_via_hole_import` is set to **yes**.

In addition to `ecad_pin_hole_import` and `ecad_via_hole_import`, you can use the `ecad_load_filtered_holes_to_ui` configuration option to achieve the required results. When you these configuration options together, `ecad_load_filtered_holes_to_ui` controls the import of **PIN** and **via** holes. That is, hole types **PIN** and **via** are completely filtered out or their import status in **Creation Method** is set to **Filter Out** in the **ECAD Input - Board** dialog box as follows:

- All three configuration options set to **no** - Holes of type **PIN** and **via** are completely filtered out and are not listed in the **ECAD Input - Board** dialog box. You cannot recover them or import them back into the design.
importing and visualizing 3dic designs

about importing 3-dimensional integrated circuit (3dic) designs

you can import into pro/engineer three-dimensional integrated circuit (3dic) designs consisting of ic layers and ic structures and visualize the representations of their geometric objects, such as boundaries and paths, in pro/engineer. a boundary consists of a polygon or rectangle while an ic path consists of a polyline. these geometric objects in the design reference ic layers and are included in ic structures.

you require the following to import 3dic designs to pro/engineer and visualize the imported designs in pro/engineer:

- the proe_3dic license
- the openaccess (oa) libraries

the oa libraries are not distributed with pro/engineer. you must install and set up the oa libraries on your computer to use the openaccess ic database format for the import of the 3dic designs to pro/engineer.

about ic layers

the ic layers contain information about the geometric objects that reference them, such as their height and thickness, and properties such as material and thermal conductivity. the ic design defines a common height (z placement coordinate) and thickness for all geometric objects that reference the same ic layer. the xy placement coordinates of the geometric objects determine their locations while their z placement coordinate is as defined by the ic layer they reference. that is, these objects are placed along the x- and y-axes with a z-axis offset.

about ic structures

the ic structures wrap geometric objects that reference different layers in the ic design. therefore, they include geometric objects of multiple shapes and varying
heights. Several IC structures can also include geometric objects that reference a specific layer.

According to the OpenAccess IC database format used for the exchange of 3DIC design data between applications, each IC structure is a cell with at least a single view. You can create multiple instances of an IC structure in the design or the model and translate, rotate, or mirror the instances. Each instance has its own transformation information. Translation is along the x- and y-axes while rotation is around the z-axis.

**To Import a 3DIC Design into Pro/ENGINEER**

1. Ensure that the lib.defs file with the design data is located in the Pro/ENGINEER working directory before you start the import.

2. Click File > Open. The File Open dialog box opens.

3. Select All Files (*) or ECAD 3DIC OA (*.defs) as the file type in Type.

4. Select the lib.defs file from the Pro/ENGINEER working directory.

5. Click Open. The Open Access Import dialog box opens.

6. Accept the default name of the library in Library Name or select a name from the Library Name list.

   The library names in the Library Name list are of library files defined in the lib.defs file selected for import. Their corresponding cell and layout names are also defined in the lib.defs file. When you select a library name from the Library Name list, Cell Name and Layout Name automatically display the corresponding cell and layout names.

7. Accept the default name of the cell in Cell Name or select a name for the cell from the Cell Name list. If you select a name for the cell from the Cell Name list, Layout Name automatically displays the corresponding layout name.

8. Accept the default name of the layout in Layout Name or select a name for the layout from the Layout Name list.

9. Click OK to import the 3DIC design into Pro/ENGINEER.

**About Visualizing the Imported 3DIC Designs in Pro/ENGINEER**

In Pro/ENGINEER, you can visualize the IC layers and IC structures of the imported three-dimensional integrated circuit (3DIC) designs in the context of subassemblies and assembly components. The following is the representation of the 3DIC design in Pro/ENGINEER:

- The top assembly model represents the 3DIC design.
- The subassemblies of the top assembly model represent the IC structures.
• The part models assembled in the IC structure subassemblies represent the IC layers. A part model in a specific IC structure subassembly wraps all geometric objects that reference the corresponding IC layer.

• Solid extruded features represent IC boundaries and IC paths.

**Placement of Layers and Structures in the Design**

An IC layer that is referenced by geometric objects is represented as a part model in an IC structure subassembly. The part model wraps all geometric objects that reference the corresponding IC layer. It is assigned the material properties of these geometric objects and is placed in the IC structure subassembly with z-offset, according to its height specification. The geometric objects in the part model are placed on the default front datum, that is, with a z-axis offset value of 0.0. The z-location of the geometric objects in the design is based on the placement of the IC layer which is placed on the relevant height. This results in the accurate location of the geometric objects in the IC structures and the placement of the part models with the appropriate offset in the relevant IC structure subassemblies.

The IC structure subassemblies are assembled CSYS-to-CSYS in the top assembly model that represents the design. The geometric objects do not reference each other. Therefore, reassembling or relocating part components in the assembly model does not result in the relocation of other parts.

**Instancing and Transforming Structures**

You can instance IC structures because of which you can place them multiple times as components in the assembly model. Assemble each instance of the IC structure subassembly for its proper placement in the assembly model. Additionally, the instances are automatically transformed or mirrored during import. Pro/ENGINEER automatically transforms the instances, based on their transformation information, while placing them in the context of assemblies. Transformation includes translation along the x- and y-axes, rotation around the z-axis, and mirroring.

For instances with transformations that includes translation or rotation, or both, the translated and rotated instances reference the IC structure subassembly that is instanced. Translation and rotation do not create additional models. If an instance contains mirroring information, a separate subassembly is automatically created with the same geometry as the IC structure or its instance in a mirrored state. This subassembly is assigned the name, MIRR_<name of the IC structure being mirrored>.asm.

**Note:** You cannot mirror an IC structure subassembly that includes other IC structure subassemblies. You can only mirror leaf components.

**Inclusion of a Layer in Many Structures**

The IC structures include geometric objects that reference different layers in the IC design or several IC structures can include geometric objects that reference a specific IC layer. For IC structures that include geometric objects referencing the same IC layer, the IC layer is included in each of the IC structure subassemblies as a
unique part model. That is, this part model occurs multiple times, one for each IC structure subassembly in which the IC layer is included. Each part model is unique because it consists of only those geometric objects that are included in the corresponding IC structure. The layers are, therefore, assigned unique names, that is, the layer name is followed by its index, for example, <Layer name>_<Layer index>.PRT.

If geometric objects that reference the same layer and placed in the same part model overlap, Pro/ENGINEER merges their continuous and sharp geometry in the part model. Pro/ENGINEER does not merge the geometry of interfering or overlapping objects when they belong to different part models or subassemblies. Instead, Pro/ENGINEER treats the part models or subassemblies as if there was no interference or overlap.

**Boundary and Path Representations**

The IC paths are created as thick extrudes with two-sided depth option. The boundaries and paths of the IC layers are assigned unique names, for example, **IC_BOUNDARY_#** and **IC_PATH_#**, respectively.

**Thermal Conductivity and Material Properties of Layers**

Thermal conductivity and material properties of the geometric objects, contained as information in the IC layers they reference, are assigned as material properties to the part models in Pro/ENGINEER. The **THERMALCONDUCTIVITYLATERAL** values are mapped to material property element values of $K_x$ and $K_y$ while the **THERMALCONDUCTIVITYVERTICAL** value is mapped to the $K_z$ value in Pro/ENGINEER.

If several IC structures include geometric objects that reference the same IC layer, thermal conductivity and material properties of the geometric objects are also duplicated the same number of times as this IC layer is included as a unique part model in each of the IC structure subassemblies. Therefore, to modify the material properties of this IC layer in Pro/ENGINEER, you must modify the material properties of each of the occurrences of this part model in the various IC structure subassemblies.

**Model Length and Material Property Units**

Model length and thermal conductivity material property units in the IC design are defined as follows:

- Model length is set to Micron units.
- Thermal conductivity is set to $N/(\text{Sec}^\ast\text{C})$ units.
Limitations in Representation

While most geometric objects of the imported three-dimensional integrated circuit (3DIC) designs, such as text notes and path types (truncated, extended, and variable), find their representations in Pro/ENGINEER, the following are not represented in Pro/ENGINEER:

- Geometric objects that include one or more crosses, intersections, and dots
- Geometric objects that include lines other than straight lines
- Geometric objects with complex, intersected shapes and open-ended loops
- Geometric objects of IC layers that do not include height or thickness dimensions
- The IC structures with no shapes or those with geometric objects in IC layers with zero thickness
- Paths with zero or negative width value
- Rounded path type
- The IC tier
- The IC data or properties, such as direction, pitch, FILL layers, and so on
- The LEF file records, such as MACRO, VIA, VIARULE, PIN, and so on

Pro/ENGINEER Mechanica objects are not created. The geometry of the overlapping or interfering objects of different layer parts or subassemblies are ignored. Holes and rounded sections are represented as split shapes or sections. The $ in the object name is converted to an underscore because including $ in object names is not the Pro/ENGINEER convention. The maximum number of assemblies that you can nest, that is, place an IC structure subassembly within another IC structure subassembly, is the Pro/ENGINEER range of 25 generations.

About Using the OpenAccess Format

You can use the OpenAccess Integrated Circuit (IC) database format with its API libraries to import and visualize three-dimensional integrated circuit (3DIC) designs in Pro/ENGINEER. Pro/ENGINEER supports OpenAccess version 2.2.6 (2.2_p044). The OA libraries are licensed and are not distributed with Pro/ENGINEER. You must install and set up the OpenAccess (OA) libraries and environment on your computer. Additionally, you must also acquire the PROE_3DIC license for the import of the 3DIC designs to Pro/ENGINEER.

The OA format stores the IC information on the disk and this format is used to communicate IC data between applications. The OA format is as follows:

- The Technology directory with its various IC layer directories.
- The Library directory with cells that are IC structure directories.

Each IC structure directory is a cell with at least a single view file. A view is referenced as a layout.
The *lib.defs* file is a top-level file that includes directory names that are the OA libraries. It consists of the names of the Technology directories and the Library directory, and additional design information.

**Note:** The *lib.defs* file must be located in the working directory in Pro/ENGINEER.

**Converting GDS2-based IC Formats to OA**

While the 3DIC designs that you import into Pro/ENGINEER are based on the OpenAccess database format, they must also be based on the GDS2 format or be totally compatible with the GDS2 format. However, you cannot directly import GDS2 files into Pro/ENGINEER although GDS2 is a standard IC format and Pro/ENGINEER supports the GDS2 objects and design structure. You must, therefore, convert a GDS2 file to the Pro/ENGINEER-compatible OA format.

In addition to the API library, the OA package includes converters that allow such conversions of different file formats. The following example shows how to convert a GDS2-based file, *.gds*, to OA.

Start the conversion with a directory containing the *.*gds, *.*pipo, and the *.*lef files. In addition to the *.*gds file that has the information about the IC structures, the *.*pipo and *.*lef files are also required because these files have the following design data:

- *.*pipo - Information about the mapping of layer names to layer IDs
- *.*lef - Layer information

Run the conversion script as follows to import *my_lib* (library name) and create the Technology library:

```
lef2oa -lef <filename with .lef extension> -lib <library name to be created> -techLib <technology library name to be created> -DMSystem oaDMFileSys -techDMSystem oaDMFileSys
```

Import the GDS files as follows:

```
strm2oa -lib <library name to be created> -gds <filename with .gds extension> -DMSystem oaDMFileSys -techLib <technology library to use> -layerMap <filename with .pipo extension>
```

The *.*gds file with layer numbers and the *.*lef file with its layer names require the *.*pipo file. The *.*pipo file includes layer mapping information that is required between the layer names used in the *.*lef file and the layer IDs in the *.*gds file.

**Note:** If the OA design is not created properly, you must specify the same name for -lib and -techLib command-line switches of the *lef2oa* and *gds2oa* conversion scripts.

**Troubleshooting the Import of 3DIC Designs**

The following are troubleshooting guidelines to be observed when importing 3DIC designs into Pro/ENGINEER. Check for error reports with the message lines, 3DIC...
Import: in the message area when you encounter problems during the import of 3DIC designs.

- Perform the following checks when the OpenAccess lib.defs file is not found in the File > Open dialog box:
  - The PROE_3DIC license that you have acquired is switched on.
  - The lib.defs file with the design data is located in the working directory of the application.
  - You have used All (*.*) as the file type filter option in the File > Open dialog box.
  - When the OA DLL fails to load and Pro/ENGINEER prints the following error:
    3DiC Import: Initialization of ecad_oa.dll failed

Verify that the local installation of OpenAccess is complete and not partial and check the location of the DLLs and shared objects. OpenAccess assumes that the DLLs and shared objects are placed accurately in their locations.

- On UNIX, the standard library path environment variable, LD_LIBRARY_PATH, must include the path to the OpenAccess optimized shared objects directory. The relative path in the installation is as follows:
  [Local oa root]/lib/sunos_58_64/opt

- On Windows XP, the PATH environment variable must include the path to the OpenAccess DLLs. To set the PATH environment variable, right-click My Computer > Properties. In the System Properties dialog box, click Advanced > Environment Variables, and type the PATH variable in User variables. The relative path in the OA installation is as follows:
  [Local oa root]/bin/win32/opt

- When Pro/ENGINEER fails to import an OpenAccess database:
  - Make sure that you have used the OpenAccess 2.2.6 (2.2_p044) database.
  - Check if the OA installation is local to your computer, on a local path, and not on a server.
  - Check whether the platform is appropriate for the import.
    **Note:** The supported platforms are Sun Solaris (64-bit), X86 Sun 64 (AMD), and Windows XP (32-bit).
  - Check the database. If you have used a DMTurbo-based OA database, run oaDMTurboServer before the import.

- If Pro/ENGINEER quits while loading the OpenAccess database, make sure that the PROE_OA_TECH_LIB_NAME environment variable is set to the correct tag of the technology library as specified in the lib.defs file. The technology library name is not the actual directory name on the disk.
If the technology library is not properly attached to the design, you must explicitly specify the tag of the technology library during the import. Use the PROE_OA_TECH_LIB_NAME environment variable as follows to specify the correct tag of the technology library:

```
setenv PROE_OA_TECH_LIB_NAME my_tech_lib
```

### Using Keepin and Keepout Areas

#### About Keepin and Keepout Areas

ECAD keepin and keepout areas specify where you can or cannot place components to avoid interfering with other components or electrical routing. In Pro/ENGINEER, create keepin and keepout areas as cosmetic features of a board part. While creating cosmetic features, you can select edges of other ECAD areas. An ECAD area can be used in Sketcher to create entities from edges or datum curves or to create draft entities at an offset from edges by clicking \[\text{Editor} \] or \[\text{Editor} \], respectively. ECAD adds the necessary commands to the **COSMETIC** and **PROJ SECT** menus in the part mode.

In Pro/ENGINEER, keepin and keepout areas can have a closed 3D volume, represented by a quilt. Use these quilts to perform a clearance and interference check to determine whether an ECAD component violates the keepin and keepout areas, even if the component is entirely within the keepout volume.

The *ecad_exp_both_two_areas* configuration option enables you to export an ECAD area with different heights for above and below board conditions. Use the **YES** option to export both-sided keepin and keepout ECAD areas as two individual areas (top and bottom).

The following table lists the Pro/ENGINEER cosmetic area feature types and the corresponding IDF region names.

<table>
<thead>
<tr>
<th><strong>PRO/ENGINEER ECAD AREA</strong></th>
<th><strong>IDF ECAD AREA</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Place Keepin</td>
<td>Placement Outline Section</td>
</tr>
<tr>
<td>Place Keepout</td>
<td>Placement Keepout Section</td>
</tr>
<tr>
<td>Place Region</td>
<td>Placement Group Area Section</td>
</tr>
<tr>
<td>Route Keepin</td>
<td>Route Outline Section</td>
</tr>
<tr>
<td>Route Keepout</td>
<td>Route Keepout Section</td>
</tr>
<tr>
<td>Via Keepout</td>
<td>Via Keepout Section</td>
</tr>
</tbody>
</table>

Remember the following characteristics of keepin and keepout areas:

- As with other sketched cosmetic features, you need not dimension or regenerate keepin and keepout areas.
- Nondimensioned, nonregenerated areas are always nonparametric.
- Use Name in the PART SETUP menu to name keepin and keepout area features.
- You can add parameters to the keepin and keepout area features such as board_side or routing_layers.
- When you export keepin areas from Pro/ENGINEER through ECAD, the value of their height exported to the interface file is 0.0. Manually edit the interface file or use the ECAD application to change this to a nonzero value if necessary.
- You can display keepin and keepout areas as 3D volumes, provided the value of their height value is greater than 0.0 by redefining the feature attributes and checking or clearing the 3D Volume option.

To Add a Keepin or Keepout Area

1. In a part, click Insert > Cosmetic > ECAD Area. The ECAD Area dialog box opens.
2. Under the Definition tab, you can define the type of ECAD area by selecting one of the following from the Area Type box:
   - Place Keepin - Creates a placement keepin region. You can specify the area height above and below the board while creating this region. The default height is zero. When exporting a file Place Keepin is not available for the Dazix format.
   - Place Keepout - Creates a placement keepout area. You can specify the area height above and below the board while creating this region. The default height is zero. When exporting a file Place Keepout is not available for the Visula interface.
   - Place Region - Creates a placement region. When exporting the file Place Region is available only with IDF format.
   - Route Keepin - Creates a routing keepin region where routing actions are permitted. When exporting a file Route Keepin is available only with IDF format.
   - Route Keepout - Visual way to indicate that you are not to route in this area. When exporting a file Route Keepout is available only with IDF format.
   - Via Keepout - Visual way to indicate that you are not to create vias in this area. When exporting a file Via Keepout is available only with IDF format.

Note: You can redefine an ECAD area by switching between the available types in the Area Type box in the ECAD Area dialog box that opens when you select the required ECAD area and click Edit > Definition.
3. Click Sketch to select a sketching plane and a reference plane.
4. Sketch the required area and quit sketcher.
5. Select the **3D Volume** check box to determine whether the area appears with a 3D quilt. Only **Place Keepin** and **Place Keepout** type of ECAD areas accept 3D volume on one or two sides.

6. If you have selected **3D Volume**, you can define the following options from the **Depth Options** box:
   - **One Side Only** - Creates a volume on one side of the board only. Specify a value for **Depth**.
   - **Two Sides Symmetrical** - Places the selected ECAD area on the top and bottom sides of the selected surface symmetrically. Specify a value for **Depth**.
   - **Two Sides Not Symmetrical** - Places the ECAD area on the top and bottom sides of the selected surface asymmetrically. Specify a value for **Depth** and **Depth2**.

7. If required, create a meshed region by clicking the **Xhatch** check box.

**To Assign a Group Name to an ECAD Area**

Add the **Component_Group_Name** feature parameter to a keepin area to specify a component group name. This parameter corresponds to the Component Group Name parameter for IDF. This feature is automatically created when you import a model with a placement region group name.

**Exporting Data to ECAD**

**About Exporting ECAD Data**

You can export board, part outline, and placement data from the part level or the assembly level. You can use any of the available translator formats, the IDF or the **ECAD EDA (*.eda)** neutral format. You can only export ECAD assemblies to the **ECAD EDA (*.eda)** format.

Each component to be exported needs a coordinate system to identify the part origin, and a section plane selected to represent the footprint. When you export individual parts, you are prompted for each. If you assigned a default value to **ecad_comp_csys_def_name** in the **config.pro** file, and named the origin coordinate system the same value, you are not prompted for the coordinate system.

When you export from the assembly mode, a dialog box handles the coordinate system selection, component name, and reference designator values, and allows the export of selected items.
**To Export Board Outline and Component Assembly Data**

You can export a board outline (including any holes) and component placement information from Pro/ENGINEER through ECAD.

1. In the assembly to be exported, click **File > Save a Copy**. The **Save a Copy** dialog box opens.

2. From the **Type** list, select the type of ECAD package.

3. Specify a new file name in the **New Name** box, if required, and click **OK**. The **ECAD Save As Assembly** dialog box opens.

4. Select the IDF version from the **IDF Version** list. IDF Version 3.0 is the default. The board, all the components in the assembly, and the other outline components are listed with an export status *yes* or *no* in the **Board** and **Component Placement** text boxes. A coordinate system to be used as an origin is also specified. Use the dialog box to add or edit the coordinate systems.

5. If required, select the board or component listed in the **ECAD Save As Assembly** dialog box and click **Change Export Status** to include or exclude the selected object from being exported.

   **Note:** If parts do not have coordinate systems, they are not included in the export.

6. If required, click **Open Log Window** for more information on the export operation.

7. Click **OK**. Pro/ENGINEER exports the board outline and component placement information to the selected ECAD package. The **ecad.log** file contains warnings or error messages, if any.

**To Export Board or Component Parts**

In Part mode, you can export the outline of the current board (including any holes) or component. If the part is a board, you can also export its keepin and keepout areas. To be exported, a part must be active. You can export a component outline only when you are in Part mode.

1. Open a part in Pro/ENGINEER and click **File > Save a Copy**. The **Save a Copy** dialog box opens.

2. From the **Type** list, select the type of ECAD package to which you want to export the part.

   To export the board to the Allegro, Dazix, and Visula file formats, you must set the **ecad_use_legacy_formats** configuration option to *yes*. By default, these file formats are not available in the **Save a Copy** dialog box.

3. Specify a new file name in the **New Name** box, if required, and click **OK**. If you have selected the **ECAD IDF (*.emn)** type, then the **ECAD Save As - Board** dialog box opens.
If you have selected the **ECAD Lib IDF (*.emp)** type, then the **ECAD Save As Component** dialog box opens. IDF version 3.0 is the default. You can select IDF 2.0 or BOARDSTATION from the **Format Options** list if required.

**Note:** **Format Options** is not available for other ECAD file formats such as ALLEGRO, VISULA, or DAZIX.

4. Under **Output As** select board or panel for export.

5. Specify the coordinate system to be used for export in the **References** field.

   **Note:** If you have set a coordinate system value for the **ecad_comp_csys_def_name** configuration option, the **Coordinate System** box automatically displays this value.

6. If you have selected the **ECAD Lib IDF (*.emp)** type to export a component, then you must specify a section plane to represent its outline. In the **ECAD Save As - Component** dialog box, specify a cross-section or a planar surface to export as the outline:
   - **Plane Intersection** - You can either select the component planar surface or Pro/ENGINEER uses the default surface.
   - **XSection** - You can either select the cross-section or specify its name.

7. If required, click **Open Log Window** for more information on the export operation.

8. Click **OK**. Pro/ENGINEER exports the part to the selected ECAD package.

**To Export a Panel File in Assembly Mode**

You can export a panel file from Pro/ENGINEER through ECAD. The assembly is exported as a panel file if the first component of the assembly has the **ECAD_PART_TYPE** model parameter set to **PANEL**.

1. In the assembly mode, click **File > Save a Copy**. The **Save a Copy** dialog box opens.

2. Select **ECAD IDF (*.emn)** for the type of ECAD export and click **OK**. The **ECAD Save As Assembly** dialog box opens.

3. Select **IDF 3.0** from the **IDF Version** box in the **ECAD Save As Assembly** dialog box.

4. Select the export status and coordinate system to be used.

5. If required, click **Open Log Window** for more information on the export operation.

6. Click **OK**. Pro/ENGINEER exports the assembly as a panel file.
To Export a Panel File in Part Mode

You can export a panel file from Pro/ENGINEER through ECAD in the part mode.

1. In the part mode, click **File > Save a Copy**. The **Save a Copy** dialog box opens.

2. Change the type to **ECAD IDF (*.emn)**, specify the required name for the output file in the **New Name** box, and click **OK**. The **ECAD Save As – Board** dialog box opens.

3. Select **IDF 3.0** from the **Format Options** box in the **ECAD Save As – Board** dialog box.

4. Under **Output As**, select **Panel**.

   **Note:** **Output As** is available only for the IDF 3.0 format.

5. From the **References** section, select the **Coordinate System** for export.

   **Note:** If you have set a value for the `ecad_board_csys_def_name` configuration option, the **Coordinate System** box automatically displays this value.

6. Select **Bottom Side** and **Top Side**. By default, Pro/ENGINEER uses the default sides.

   **Note:** If Pro/ENGINEER finds the top and the bottom sides, then the **Top** and the **Bottom** collectors automatically display the current values. You can select a different value if required. If a unique top or a bottom side is not found, **OK** in the **ECAD Save As – Board** dialog box remains unavailable for selection. The **Top** and **Bottom** collectors can only pick faces or datums that are parallel to the XY plane of the selected coordinate system.

7. If required, click **Open Log Window** for more information on the export operation.

8. Click **OK**. Pro/ENGINEER exports the panel file in the part mode.

**Tip: Placing Subassemblies as Components for Export**

When used correctly, the `ecad_hint.map` file can place a subassembly as a component just as you can place a part as a component. You cannot export component outlines of assemblies. If you place subassemblies as components, the following restrictions apply:

- If the current directory or session contains a part with the same name as the subassembly, the system uses the part rather than the subassembly.

- You can use a subassembly only if it contains an assembly coordinate system with the appropriate datum planes. This assembly coordinate system must be built explicitly on three assembly datum planes and have an orientation recognized by ECAD.
About Exporting ECAD Data to the EDA Format

You can export Pro/ENGINEER ECAD assemblies to the neutral ECAD EDA (*.eda) format with File > Save a Copy. You can then use these *.eda files to share and propose assembly design changes with ECAD users in the ECAD-MCAD collaboration mode as follows:

- Save an ECAD assembly design as a *.eda file when you want to share the assembly design with ECAD users working in InterComm Expert.
- Create *.eda files at different stages of the design, compare these design iterations, and use the incremental data as proposals for change.

The following ECAD objects of the assembly designs are exported to the ECAD EDA (*.eda) format:

- Board outlines
- Component profiles, placements, and properties
- ECAD areas, such as, region and place, route, and via keepin and keepout
- Mounted and drilled holes
- Other outlines
- Notes

Note: You cannot export part models and paneled outlines to the ECAD EDA (*.eda) format.

To Export ECAD Data to the EDA Format

1. Open an ECAD assembly.
2. Click File > Save a Copy. The Save a Copy dialog box opens.
3. In the Type box, select ECAD EDA (*.eda).
4. In New Name, specify a name for the *.eda file.
5. If the ECAD assembly consists of subassemblies, define a bounding box for the components of the subassemblies to export them with their placement information.
6. Specify a cross-section or a planar surface for the maximum representation of irregularly shaped board components or rich 3D components in the exported model.
7. Perform the following steps when an error message and the Select menu appear for an ECAD assembly with multiple top and bottom surfaces and no unique top and bottom sides defined.
   - Select the top and bottom planes or surfaces on the model that are normal to the z-axis of the assembly or board coordinate system.
   - Click OK on the Select menu.
8. Click OK in the Save a Copy dialog box.

Exporting Board and Components to EDA Format

The details of the export of board outlines and ECAD assembly components to the EDA format are as follows.

Board Outlines that Include Extruded Sections and Cutouts

Cutouts and extrudes of board outlines are retained as board geometry in the *.eda files. Round cutouts are exported as drilled holes. For boards with more than a single coordinate system, if the ecad_board_csys_def_name configuration option is not set to the name of one of the coordinate systems, Pro/ENGINEER uses the first coordinate system it finds. The z-axes of the component and board coordinate systems must be parallel and aligned with each other. The geometry of the board and the components are placed with reference to the coordinate system of the board. For boards with multiple surfaces, the geometry is placed with reference to the top surface of the first extrude feature on the board.

The BOARD value of the ECAD_PART_TYPE model parameter is retained in the *.eda files. The value of the OWNER parameter in the IDF source files are also retained. The depth of the extrude feature defines the thickness of the board in the *.eda files.

Component Placement

The components are exported with the coordinate system name that is assigned as the default value of the ecad_comp_csys_def_name configuration option. This coordinate system identifies the part origin and must be aligned with the coordinate system of the board. Pro/ENGINEER uses the coordinate systems of the component and the board to determine the placement and the offset. When the ecad_comp_csys_def_name configuration option is not set to a coordinate system name or no default coordinate system is defined, the components are exported with the coordinate system of the first component. The z-axes of the coordinate systems of this component and the assembly must be parallel and aligned with each other.

The export includes the following items:

- Reference designators
- Component names
- The ECAD_NAME and ECAD_ALT_NAME component parameters
- Top or bottom placement information
- Placement status
- Rotation about the z-axis
- The x-, y-, and z-offset values
Component Outlines

The component outlines are exported with the default xy-placement coordinates of their default coordinate system. Use the `ecad_comp_csys_def_name` configuration option to assign a name for the coordinate system to be used for the export. You can also assign a cross-section name as the value of the `ecad_comp_xsec_def_name` configuration option. The component names, types (the `ECAD_PART_TYPE` parameter), geometry profiles, and properties are exported to the `*.eda` files.

Exporting Holes and ECAD Areas to EDA Format

Feature IDs, geometry profiles (the same as IDF version 3.0), the `ECAD_OWNER` parameter values of hole features, ECAD areas, other outlines, and notes are exported to the ECAD EDA (`*.eda`) format. The additional details of the export are as follows.

Hole Features

Hole features and round cutouts are exported as via drill holes. The hole geometry is on the drill diameter sublayer while the hole properties are located on via pad sublayers. The drill diameter is displayed on the top layer. Mounted holes are visible on all layers, including via pad sublayers.

Hole diameters and the x- and y- offsets for the placement of holes are exported to the `*.eda` files. The `ECAD_OWNER`, `ECAD_HOLE_TYPE`, `ECAD_PLATING_STYLE`, and `ECAD_ASSOCIATED_PART` feature parameters are exported as the Hole Owner, Hole Type, Plating Status, and Associated Part properties, respectively. The Plating Status attribute of the drill hole object stores the `ECAD_PLATING_STYLE` property. The drill diameter sublayer displays the Plating Status attribute of the drill hole.

ECAD Areas

Make sure that the `ecad_area_default_import` configuration option is set to the value, `cosm_area`, so that ECAD areas are treated as cosmetic area features. When the `BOARD_SIDE` feature parameter is set to the value BOTH, two place keepin, place keepout, or ECAD regions are created in the `*.eda` file. One is assigned the top layer and the other is assigned the bottom layer, according to the layer specifications in EDA.

The additional details of the export of ECAD areas are as follows:

- **Place keepin and place keepout** - The TOP, BOTTOM, or BOTH values of the `BOARD_SIDE` parameters and the height specified in the design files are exported to the `*.eda` files.

- **Region** - The `COMPONENT_GROUP_NAME` parameter is exported as the Group Name property.

- **Route keepin, route keepout, via keepin, and via keepout** - The TOP, BOTTOM, BOTH, ALL, and INNER values of the `ROUTING_LAYER` feature parameters in the design files are exported to the `*.eda` files. These values of `ROUTING_LAYER` determine the layers of the ECAD area. They are mapped to the
actual and corresponding **TOP, BOTTOM, BOTH, ALL, and INNER** layers in the *.eda files.

**Other Outlines and Notes**

To export other outlines, you must create a component with the attribute name, **Other Outline**. Other outlines in the design file retain their height, top and bottom placement information, and the **ECAD_OWNER** model parameter as the **Owner** property in the *.eda files.

Notes are exported to the *.eda files with their text values, x- and y- offset values, length, and height.

Model data, such as the model name, part number, version, units, the location, timestamp, and other user-defined details, are also exported to the *.eda files.

**Exporting Irregularly Shaped Components**

If the maximum representation of a component is not at the default xy-placement coordinates of the default coordinate system, you must add a cross-section where the representation is maximized. This ensures the accurate definition of the component that is exported.

**Note:** Irregularly-shaped components of IDF files, imported into Pro/ENGINEER and exported to the **ECAD EDA** (*.eda) format, are adequately represented in the *.eda files.

For complex or irregularly shaped components, you can add the cross-section parallel to the default xy plane and at the maximum material location, as part of the design process. Additionally, set the **ecad_comp_xsec_def_name** configuration option to the name of this cross-section.

This is a one-time task and the cross-section or planar surface is saved to the component model. This cross-section is available for all subsequent exports of the board, even if this component is used in other assemblies. Pro/ENGINEER uses this cross-section while creating the 2D outline of the component model.

**To Add a Cross-Section to Export Irregularly Shaped Components**

1. Specify a plane to be used as the cross-section for the export of irregularly shaped or rich 3D components as the value of the **ecad_comp_xsec_def_name** configuration option.

2. Open the ECAD assembly or board with the irregularly shaped or rich 3D components.

3. Click **View > View Manager**. The **View Manager** dialog box opens.

4. Click the **XSec** tab and **New**.

5. In **Name**, specify the name of the plane set as the value of the **ecad_comp_xsec_def_name** configuration option. The **XSEC CREATE** menu appears in the **Menu Manager**.
6. Click **Planar** and **Done**. The **SETUP PLANE** menu appears.

7. Click **Make Datum**. The **DATUM PLANE** menu appears.

8. Click **Offset**. The **OFFSET** menu appears. The **Select** menu also appears and you are prompted to select a plane or a coordinate system.

9. Select a section plane or a planar surface on the model to use as the cross-section.

10. Click **Enter Value** on the **OFFSET** menu.

11. Enter a value for the offset.

12. Click **Done** on the **DATUM PLANE** menu.

13. Click **Close** in the **View Manager** dialog box.

### Working in ECAD-MCAD Collaboration Mode

#### About the ECAD-MCAD Collaboration Mode

The ECAD-MCAD collaboration mode provides a collaborative environment to ECAD and MCAD users. They can use Pro/ENGINEER and InterComm Expert to dynamically investigate design issues and propose and share design changes.

To begin the collaboration in Pro/ENGINEER, open an ECAD assembly consisting of a board part, set the default master representation, and click **Applications > ECAD Collaboration**.

You can perform the following collaborative tasks in the ECAD-MCAD collaboration mode:

- Compare two iterations of an ECAD assembly design to propose incremental changes.
- View the object data differences as a summary report in the ProductView Validate application that opens in a separate window.
- Save the differences in the ECAD assembly designs that constitute the incremental change to an external IDX file that is compliant with the EDMD schema.
- Analyze object data with cross-highlight, zoom, and a preview of the design states.
- Cross-highlight the changed object data from ProductView Validate to the Pro/ENGINEER graphics window or InterComm Expert and vice-versa.
- View and analyze ECAD proposals in ProductView Validate and set the proposed changes to the Accept or Reject transaction state.
- Commit the accepted object data to the assembly database in Pro/ENGINEER.
- Update the IDX file and the ECAD assembly design with the incremental changes.
• Handle feature and component failures and downstream issues during the update of the assembly design.

• Set the preview levels for the updated assembly design to gauge the performance of the assembly.

• Transmit objects and their associated design states as IDX or IMX files to InterComm Expert.

**Note:** If the ECAD assembly is empty, a message warns you that you cannot enter the ECAD-MCAD collaboration mode.

In the collaborative mode, you cannot perform feature operations, such as the redefinition or insertion of features. You cannot access the Sketcher mode, edit dimensions and parameters, or perform **Edit > Undo** or **Redo**. However, you can use the Pro/ENGINEER **View** command to change the view. You can also use **Analysis > Model > Global Interference** to check for interference when changed objects are accepted and **Analysis > Measure** for various measurements.

The ECAD-MCAD Collaboration Workflows document provides an overview of the MCAD to ECAD and ECAD to MCAD sequence of tasks.

### About the Sequence of Collaborative Tasks

You can use Pro/ENGINEER in conjunction with other ProductView applications, such as InterComm Expert, ProductView ECAD Compare, and ProductView Validate, to dynamically investigate design issues and propose and share design changes.

The sequence of the ECAD-MCAD collaboration tasks are as follows. The ECAD-MCAD Collaboration Workflows document describes in detail the sequence of tasks and the file transactions involved in the workflow between Pro/ENGINEER and ECAD.

• The creation of the initial baseline in Pro/ENGINEER and the communication of this MCAD design to the ECAD user using the EDA format.

• The sharing of this MCAD design outside Pro/ENGINEER through the dynamic interaction with the ECAD view using ProductView InterComm Expert. The Pro/ENGINEER and the ECAD users simultaneously view the relevant objects in both domains to analyze the impact of the proposed changes against ECAD details such as traces, planes, and via holes. The ECAD view is loaded from an EDA file that originates in ECAD.

• The analysis of the changes that originate in Pro/ENGINEER while referencing ECAD.

• The proposal of the incremental MCAD changes from Pro/ENGINEER while referencing ECAD.

• The proposal of the incremental MCAD changes from Pro/ENGINEER as differences between design iterations. The Pro/ENGINEER user saves incremental change proposals, one at a time, to the ECAD assembly to communicate one
change at a time to the ECAD user. Each change proposal is saved in a separate IDX file.

- The proposal of the incremental MCAD changes from Pro/ENGINEER, one at a time. Each incremental change proposal is saved to the ECAD assembly and a separate IDX file for subsequent communication to the ECAD user – one at time.

- The sharing of the proposed incremental MCAD changes with the ECAD user. The Pro/ENGINEER user views the MCAD incremental change proposals in ProductView Validate. The Pro/ENGINEER user subsequently sends them to the ECAD user to provide additional comments on the individual proposals or to exclude these proposals from the collaboration. The change proposals may not be appropriate to communicate at this time. The changes are loaded from an IDX file and change updates are saved in the same IDX file.

- The validation of the incremental changes proposed by the ECAD user. The Pro/ENGINEER user dynamically interacts with ProductView Validate to cross-highlight, visualize, analyze, comment, commit to database, and set each proposal as Accepted or Rejected. The changes are loaded from an IDX file and updates are saved in the same IDX file.

- The collaboration of the incremental changes in ECAD. The ECAD user uses the IDX files to evaluate the incremental changes from Pro/ENGINEER and to propose incremental changes to the Pro/ENGINEER user.

- The verification and validation of the MCAD and ECAD designs for differences. The Pro/ENGINEER user compares the ECAD assembly with the corresponding designs provided by the ECAD user to identify unexpected differences. The differences are saved in an IDX file.

- The setting of a new baseline between MCAD and ECAD and the exchange of the synchronized IDF file to establish a new baseline between the ECAD and the MCAD users.

**Proposing Incremental Changes from Pro/ENGINEER**

When the design changes originate in Pro/ENGINEER, the MCAD to ECAD collaboration scenario is as follows:

- Generate two iterations of an ECAD assembly design as *.eda files in a single or different sessions of Pro/ENGINEER. Generate the *.eda files in the ECAD-MCAD collaboration mode or outside the collaboration mode with the Pro/ENGINEER File > Save a Copy command.

- Compare the two *.eda files with the Utilities > MCAD/ECAD Compare option in the ECAD-MCAD collaboration mode. The comparison identifies the parametric variations in the two iterations of the ECAD assembly.

- The comparison automatically generates an IDX file with the design changes in the two iterations of the ECAD assembly design. ProductView Validate displays the comparison results.
Analyzing the design changes in ProductView Validate. These variations in design data are only the proposed changes.

Accept or reject specific design changes that you have verified in ProductView Validate.

Update the assembly database and the IDX file with the specific changes that you have accepted.

Transfer the IDX file with the design changes to the ECAD engineer.

As an ECAD engineer, you can view the contents of the IDX file created in Pro/ENGINEER in standalone ProductView Validate. You can select the changed design objects and cross-highlight them in Pro/ENGINEER. After verifying the changes with cross-highlight across InterComm Expert and Pro/ENGINEER, you can accept or reject changes, update the IDX file, and transfer the IDX file to the Pro/ENGINEER user.

**Proposing Incremental Changes from ECAD**

The collaboration scenario from ECAD is as follows:

- The ECAD user receives the IDX file from the Pro/ENGINEER user.
- The ECAD user views the contents of the IDX file and the design changes proposed by the Pro/ENGINEER user in the ProductView Validate application. These data differences are only the proposed changes.
- The ECAD user verifies the proposed design changes and other data by cross-highlighting the design objects from InterComm Expert into Pro/ENGINEER.
- The ECAD user accepts or rejects the proposed design changes and uses ProductView ECAD Compare to propose additional changes to the Pro/ENGINEER user.
- The ECAD user updates the ECAD assembly database and the IDX file with the selective and incremental changes that are accepted.
- The ECAD user transfers the updated IDX file to the Pro/ENGINEER user.

The Pro/ENGINEER user can view the contents of the updated XML file in ProductView Validate. The Pro/ENGINEER user selects the changed design objects and the additionally proposed changes of the ECAD user, highlights and zooms them into focus in Pro/ENGINEER or cross-highlights them in InterComm Expert. The Pro/ENGINEER user accepts or rejects the verified changes, updates the assembly in Pro/ENGINEER and the IDX file, and transfers the IDX file with the design changes to the ECAD user.

The Pro/ENGINEER and ECAD user achieve design synchronization through several iterative proposals and design changes.
**About Comparing ECAD Assembly Designs**

You can compare two iterations of an ECAD assembly and use the differences identified as proposals of change. The ProductView Validate application automatically opens in a separate window and displays the results of the comparison as transactions at runtime.

Select the node of a transaction in the **Transaction Summary** frame of ProductView Validate to view the corresponding object data in the **Transactions List**. ProductView Validate displays the following variations in data between the baseline and the current ECAD assembly. You can save the comparison results to an IDX file.

- The object data differences.
- The board outline and component changes in the context of the current assembly design.
- The changed objects, such as the modified board outline and the added, deleted, moved, and modified components of the assembly design.

**Note:** If you do not assign unique reference designators to all patterned components of an ECAD assembly, the comparison only shows one of the patterned components. Additionally, you cannot add a component to the assembly design when a component with the same reference designator already exists in the assembly.

You can set the baseline *.eda file for the comparison in Pro/ENGINEER or ECAD. In Pro/ENGINEER, you can save an ECAD assembly as a baseline *.eda or the native Pro/ENGINEER *.asm file. The current assembly design is compared with its baseline *.eda or *.asm file.

**Note:** You cannot compare panel assemblies.

**To Set the Baseline EDA File for the Comparison**

1. Open an ECAD assembly.
2. Click **File > Save a Copy**. The **Save a Copy** dialog box opens.
3. In the **Type** box, select **ECAD EDA (*.eda)**.
4. In **New Name**, specify a name for the *.eda file.
5. Click **OK**.

**To Compare the Current ECAD Assembly With its Baseline**

1. Open the ECAD assembly design that you saved as the baseline.
2. Modify the board outline of the assembly design.
3. Add, delete, move, and modify the components of the assembly design, as required.
4. Click **Applications > ECAD Collaboration**.
5. Click **Utilities > MCAD/ECAD Compare** on the **ECAD-MCAD Collaboration Mode** dashboard. The **Select Assembly to compare against** dialog box opens.

6. Click **Compare against an *.eda file** or retain the default selection of **Compare against an assembly iteration**.

7. Click the **File** folder icon. **Type** is set to **Assembly (*.asm) or ECAD EDA (*.eda)** in the **Open** dialog box, depending on your selection of **Compare against an *.eda file** or **Compare against an assembly iteration**.

8. Select the baseline *.eda or *.asm file.

9. Click **OK**. **ProductView Validate** opens in a separate window displaying the comparison results.

   **Note:** The comparison fails when no unique top and bottom surfaces are defined for an ECAD assembly or PCB design with multiple top and bottom surfaces. To continue with the comparison, select the top and bottom planes or surfaces that are normal to the z-axis of the coordinate system.

---

**Editing the Settings for Units**

You can edit the settings for units in the **default_config.xml** file that the **ProductView ECAD Compare** utility uses to achieve consistency between the design and the comparison results. For example, for the IDX file to display units in millimeters, you can change the settings for units from **mils** to **millimeters** in the **default_config.xml** file. This file is located in C:\Program Files\PTC\ProductView ECAD\resources\cadcompare\text\resource\. The **ProductView ECAD Compare** utility determines the various parameter settings in the **default_config.xml** file before it uses them during the comparison of the ECAD assembly designs.

**Note:** You must back up the **default_config.xml** file before you edit it. Do not change any other parameter settings while you edit the settings for units. Changing other parameter settings in the **default_config.xml** file can affect the accuracy of the comparison results.

If you have the additional license for **ProductView ECAD Compare**, you can access **Tools > Options** in **ProductView ECAD Compare** and load the **default_config.xml** in the **Options** dialog box. You can then select the units to edit from the **Units** list. The units available are Inch (In), Mil (mil), Microinch (uin), Centimeter (cm), Millimeter (mm), and Micron (um). If you do not have the license for **ProductView ECAD Compare**, open the **default_config.xml** in a text editor or the Microsoft XML Editor, and edit the settings for units.

Alternatively, you can change the settings for units in the **ProductView Validate** application, after the comparison of the design files. Click **Options > Active Units** and change the units from **Mils** to **Millimeters** when **ProductView Validate** displays the comparison results. You can save the changed settings to the IDX file.

You can refer to the Online Help of **ProductView ECAD Compare** and **ProductView Validate** for more information.
About the IDX Format

The IDX (Incremental Design Exchange) format is an XML-based messaging format. It is based on the ProSTEP EDMD (ECAD Design and MCAD Design) open schema for the incremental exchange of PCB layout changes between MCAD and ECAD tools. It captures and tracks the proposed design changes initiated by the mechanical and electrical users in the ECAD-MCAD collaboration mode. It communicates design changes between ECAD and MCAD.

The IDX file is automatically generated in the Pro/ENGINEER working directory in the following instances:

- While proposing incremental changes from Pro/ENGINEER through the comparison of the ECAD assembly designs.
- During the cross-highlight of the ECAD assembly design objects between ProductView Validate and Pro/ENGINEER or between two sessions of Pro/ENGINEER.

The IDX file generated after the comparison of the ECAD assembly designs consists of the following data variations in the context of the current design:

- The parametric changes of the board outline and the ECAD assembly components.
- The addition, deletion, move, and modification of the assembly components and the board outline.

The changed design data in the IDX file are the objects for transaction and collaboration. You can validate the changed data and use the IDX file to propose design changes in a workflow across Pro/ENGINEER and InterComm Expert.

The IDX format also includes information about the following states of the changed objects:

- The current state
- The baseline state
- The reset, original, or database state

The IDX format is utilized by the following tools and applications:

- ProductView ECAD Compare for describing differences between two design iterations of an ECAD assembly.
- ProductView Validate for proposing design changes.
- Pro/ENGINEER and InterComm Expert for sending and receiving messages when changes are proposed and reviewed.

About Validating Proposed Design Changes

ProductView Validate displays the proposed design changes in the IDX file as transactions. These transactions consist of the moved, added, deleted, and modified components of the ECAD assembly and the changed board outline. You must analyze and validate these transactions before you accept or reject them and subsequently update the IDX file and the assembly database.
You can analyze selected transactions with cross-highlight and a preview of their design states from ProductView Validate to the ECAD design in Pro/ENGINEER. The preview shows the changed objects associated with the transactions in a specific state with respect to their location in the assembly. You can preview the 3D geometry of the changed objects for each of the design states in a distinct color as follows:

- **Baseline design** - The changed objects are displayed in orange.
- **Current design** - The changed objects are displayed in blue.
- **Reset design** - The changed objects are displayed in the Pro/ENGINEER database color.

To preview the different design states of a part, all parts must exist in the working directory or must be accessible through a search path. If the properties or parameters of an object change, a note is attached to the relevant object as an annotation element. It is placed along an xy annotation plane, as part of the preview.

You can zoom into focus or isolate objects associated with the transaction when you cross-highlight them. You can also place a cross-hair on the objects for easy identification in the assembly design. You can also cross-highlight the selected transactions across applications, from ProductView Validate to InterComm Expert, and open the current or the baseline design in InterComm Expert from ProductView Validate. You can include the preview states and the commands to zoom, place a cross-hair, or isolate in the cross-highlight message.

This analysis of the changed object data is useful in the context of large assemblies with numerous variations in comparison data. The IDX file maintains communication between ProductView Validate and Pro/ENGINEER or InterComm Expert during the analysis. You can refer to ProductView Validate Online Help for more information.

**About the Design States**

The various design states of the changed object data are as follows:

- **The baseline design** - The design state before the comparison of the ECAD assembly designs. The baseline is the reference state with which the current assembly design is compared.

- **The current design** - This design state includes the changes made to the assembly design after the creation of the baseline. This is the design that is compared with the baseline.

- **The reset state** - The original design state of the object, as it was in Pro/ENGINEER, before entering the ECAD-MCAD collaboration mode. It shows the actual 3D geometry with its location, shape, and state.
To Validate Proposed Design Changes

1. Open an ECAD assembly.

2. Click **Utilities > Launch ProductView Validate** on the **ECAD-MCAD Collaboration Mode** dashboard. ProductView Validate opens in a separate window.

3. Click **File > Open** in ProductView Validate. The **Select File** dialog box opens with **Type** set to IDX files (*.idx).

4. Browse and select an IDX file that contains the comparison data of the active ECAD assembly. The **Transaction Summary** frame lists the transactions as nodes and branches.

5. Select a transaction node. The **Transactions List** displays the object data of the expanded node as individual transactions.

6. Select a transaction or multiple contiguous or noncontiguous transactions. **Transaction Attributes** and **Transaction History** display the attributes and the history of the changed object.

7. Select **Cross-Highlight** on the tool bar. Alternatively, right-click and access **Cross-Highlight** or click **Communicate > Cross-Highlight Transaction** on the menu bar. The selected object highlights in red in the Pro/ENGINEER graphics window.

8. Preview the design states of the selected transaction in Pro/ENGINEER using the following options from the tool bar of ProductView Validate:

   - Displays the moved, modified, or added objects in their current state in orange. Also available as **Preview Current** when you right-click the transaction in the **Transactions List** or click **Communicate > Preview Current Transaction** on the menu bar.
     
     **Note:** Deleted components are not displayed in the preview of the current design state.

   - Displays the moved, modified, or deleted objects in their baseline state in blue. Also available as **Preview Baseline** when you right-click the transaction in the **Transactions List** or click **Communicate > Preview Baseline Transaction** on the menu bar.

9. Right-click and access **Reset tool data base** or click **Communicate > Reset Tool Database** on the menu bar to view the original design state of the moved, modified, or deleted object in the Pro/ENGINEER database color.

   **Note:** Added components are not displayed in the preview of the baseline and reset design states.
10. Select the following options on the tool bar to visually distinguish the object data associated with the transaction selected for the cross-highlight:

- (Zoom To) - Zooms into focus the objects associated with the selected transaction. Multiple objects are zoomed into focus in a fit-to-screen manner.

- (Cross-Hair) - Places a cross-hair on the objects associated with the selected transaction.

- (Isolate) - Removes graphics not related to the objects associated with the selected transaction and isolates them from all other object data in the design.

11. Click File > Launch InterComm Expert > Current Design or Baseline Design to cross-highlight the selected objects into the current or the baseline design in InterComm Expert. The message transmitted to InterComm Expert includes the visual and preview instructions.

12. Click File > Save in ProductView Validate to save transaction changes to the IDX file.

13. Click File > Close.

About the Incremental Update of the IDX File and ECAD Assembly

You can set the state of the validated transactions to Accept or Reject in ProductView Validate and commit the accepted transactions to the assembly database in Pro/ENGINEER. You can also save the transaction state changes to the IDX file. The IDX file and the assembly design are updated with the selected changed data.

The update of the IDX file and the assembly design is selective and incremental and only includes the changed objects that you have accepted. The changed objects include the modified geometry of the board outline and the added, removed, moved, and modified ECAD assembly components. The changed objects that are rejected are restored to their original state in Pro/ENGINEER, as they were before the start of the collaborative session. You can use the Pro/ENGINEER Analysis option and the Global Interference dialog box to check for interference before you reject a changed object.

Note: An added component that constitutes the incremental change, with the component model name specified in the IDX file, requires a part. If Pro/ENGINEER finds the required part, it is used by the added component. Pro/ENGINEER can find this part through the ecad_hint.map file. If Pro/ENGINEER does not find the part for the new component, it displays an appropriate message.

The incremental update of the ECAD assembly breaks dependencies and affects downstream features. The ECAD Changes Notification and the Board update - Break of dependency dialog boxes inform you about the suppressed objects, regeneration failures, the break in dependencies, and the redefinition of features. The ECAD log file also records the updates and lists the suppressed and failed
objects. Pro/ENGINEER automatically handles such feature failures and resolves downstream issues resulting from the incremental update of the ECAD assembly.

To Incrementally Update the IDX File and the ECAD Assembly

1. Validate the proposed design changes that are displayed as transactions in the Transactions List of ProductView Validate with cross-highlight and preview.

2. Make sure that Options > Communicate Messages with State Changes is selected to include transaction states in the message transmitted to InterComm Expert during a cross-highlight.

3. Right-click a validated transaction in the Transactions List or click Edit > Revise State on the menu bar to set the transaction to one of the following states:
   - **Set as Accept or Revise State > Accept** - Sets the transaction state as Accepted. The changed object associated with the selected transaction is displayed in green in the assembly design.
   - **Set as Reject or Revise State > Reject** - Sets the transaction state as Rejected. The changed object associated with the selected transaction is displayed in the Pro/ENGINEER database color.

   **OK** and **Cancel** are available on the ECAD-MCAD Collaboration Mode dashboard when you set the transaction state to Accept or Reject in ProductView Validate.

   **Note:** If you click a preview option after setting the transaction state to Accept or Reject, the Warning - Operation not supported dialog box warns you that preview of the design states is not allowed. It prompts you to set the transaction state to Unresolved.

   - **Set as Undecided or Revise State > Undecided** - Sets the transaction state to an unresolved state, neither accepted or rejected.
   - **Set as Exclude or Revise State > Exclude** - Excludes the selected transaction from the collaboration.

4. Click **File > Save** in ProductView Validate to save the transaction states to the IDX file.

5. Click **File > Close** in ProductView Validate.

6. Click **OK** on the ECAD-MCAD Collaboration Mode dashboard to commit the accepted design objects to the assembly database and quit the collaborative session. The objects that were displayed in green when accepted are displayed in the Pro/ENGINEER database color.

   **Note:** You cannot use Edit > Undo or Redo to undo or redo the ECAD assembly updates.

The ECAD Changes notification dialog box informs you about the update of the ECAD assembly and the ECAD log file with the changes. It also informs you that
some objects can fail or are suppressed during the assembly update. It prompts you to confirm the update.

The **Board update - Break of dependency** dialog box informs you about the break in dependencies and the redefinition of features.

7. Click **OK** on these dialog boxes to confirm the update of the assembly.

### About Board and Component Changes

Pro/ENGINEER uses the default settings in the **Affected Objects** panel to automatically handle feature failures and resolve downstream issues during the incremental update of the ECAD assembly. The **Affected Objects** panel performs the following tasks by default during the incremental update of the assembly:

- Checks for dependencies resulting from board and component changes.
- Controls the redefinition of objects, such as ECAD area, holes, and other components.
- Suppresses failing features.
- Displays a list of redefined and suppressed objects.

Pro/ENGINEER uses the default settings in the **Affected Objects** panel to redefine and suppress objects and features as follows:

- Automatically redefines the dependent board and objects, such as ECAD holes and areas and components. These redefined objects and components are not dependent on the lost features, especially when the edges of board outlines are deleted. They retain their original positions and use default or alternate references when reference geometry is lost and regeneration fails.
- Redefines the first extrude feature in the board outline to represent the entire board outline.
- If Pro/ENGINEER does not find the coordinate system of an affected component, it creates a coordinate system for the component. Pro/ENGINEER uses this coordinate system during the redefinition of the component.
- When redefining a pattern, Pro/ENGINEER unpatterns the pattern leader before redefining it.
- Suppresses additional features, such as cuts and extrudes that change the board outline after the assembly update, other than the first extrude which is redefined.
- Retains the top and bottom positions of ECAD holes and areas, components, and cuts after their redefinition.
- Removes the external dependencies of board objects and components.
• Automatically redefines the moved objects to remove their dependencies. After this redefinition, you can move an object or component independent of other objects or components.

• Automatically suppresses and removes nonECAD features and objects that are not redefined and fail regeneration.

Some loss of parametric behavior occurs after the assembly update because the objects have lost their original references and are redefined. The ECAD log file records the updates and lists the suppressed and failed objects.

**Note:** You cannot undo the redefinition or suppression of features.

Even if you clear the default selection of options in the **Affected Objects** panel, you cannot restore objects that Pro/ENGINEER has redefined or suppressed. However, when you apply the changes, depending on the changed settings of the **Affected Objects** panel, Pro/ENGINEER restores objects that were redefined, suppressed, or previewed. If feature failures persist when you clear the default selection of an option, use the Pro/ENGINEER **FIX MODEL** menu to redefine or suppress failing objects. You must quit the collaborative session to use the **FIX MODEL** menu.

Clearing the default selections of the redefine and suppress options in the **Affected Objects** panel improves the performance of large assembly designs.

### About Setting Preview Levels for the ECAD Assembly

The performance of assemblies after an update depends on their regeneration and processing. The following operations can take a long time and affect the performance of assemblies:

• Too many objects or components to redefine and suppress.

• The regeneration of large and complex assembly designs.

• The default settings in the **Affected Objects** panel to suppress and redefine failing objects when there are too many changes and a large number of failing objects.

You can set the following preview levels in the **Input Control** panel to control the regeneration time and performance of assemblies during their update. For best results, set these preview levels in conjunction with the selection of redefine and suppress options in the **Affected Objects** panel.

• **Full** - This is the default preview level. Pro/ENGINEER updates the assembly and the board outline with all the changed objects and the assembly is fully regenerated. All failing objects and dependent objects are suppressed or redefined, according to the default settings in the **Affected Objects** panel. All changes are visible in the assembly design and the Model Tree. However, the full regeneration of the assembly slows down its performance though this level provides an accurate preview of all the changes.

• **Partial** - This preview level only updates and regenerates the changed assembly design. The downstream dependency and failure indications are partial. All board and assembly design changes are visible in Pro/ENGINEER. However, the dependency changes are not visible until you refresh the view.
• **Light** - This preview level displays the updated board or assembly design as a 2D outline in the following preview colors of the design states:
  
  o Orange for current
  o Blue for baseline
  o Green for the accepted design states

The processing and regeneration of the assembly design is relatively faster than the preview level of **Full**. However, the changed components and the board changes with downstream issues, such as object dependencies, are not visible. To see the changes made to the board, you must move the **Preview level** slider to **Partial** or **Full**.

You can click **Load input file** to load incremental events from an IDX file.

### To Redefine and Suppress Failing Objects During Assembly Update

1. With an ECAD assembly open in Pro/ENGINEER, click **Utilities > Launch ProductView Validate** on the **ECAD-MCAD Collaboration Mode** dashboard. ProductView Validate opens in a separate window.

2. Load the IDX file with the comparison data of the ECAD assembly in ProductView Validate.

3. Select a transaction in the **Transactions List** of ProductView Validate.

4. Analyze the transaction with cross-highlight and preview of the design states.

5. Click **Revise State > Accept** to set the transaction state to **Accept**.

6. Click **Affected Objects** on the **ECAD-MCAD Collaboration Mode** dashboard.
   **Note:** All redefine and suppress options in the **Affected Objects** panel are selected by default.

7. Retain the default selection or clear one or both the following check boxes in the **Check dependencies resulting from** section:
   
   o **Board changes** - Checks the dependencies of objects affected by changes to the board geometry, such as the board outline and cutouts.
   
   o **Component changes** - Checks the dependencies of objects affected by changes to components.
   
   **Note:** Clear the default selection of these check boxes when the assembly design is very large. The options in the **Redefine affected features** section are not available when you clear the selection of these check boxes.

8. Retain the default selection or clear one or all the following check boxes in the **Redefine affected features** section:
   
   o **Components** - Allows you to redefine assembly design components.
ECAD Areas - Allows you to redefine ECAD areas.

Holes - Allows you to redefine holes on the board outline.

**Note:** Clear the default selection of these check boxes when the objects and components to redefine are many and the performance of the assembly is slow.

The Feature column in the Redefined Objects collector dynamically lists the redefined features while the Change ID column lists their corresponding feature IDs.

9. Clear the default selection of **Suppress cuts on board changes** in the Suppressed Objects section if you do not want to automatically suppress cuts. These cuts represent ECAD holes and include circular outlines.

10. Retain the default selection of the **Suppress features on Apply Changes** check box or clear its selection. This option automatically suppresses objects that fail when you click OK on the ECAD-MCAD Collaboration Mode dashboard and quit the collaborative session. The Suppressed Objects collector displays the suppressed objects.

11. Set the required preview level in the Input Control panel for a complete or partial regeneration of the assembly.

12. Click **Load input file** in the Input Control panel to load incremental events from an IDX file.

13. Click **Close** in ProductView Validate and click **OK** on the ECAD-MCAD Collaboration Mode dashboard to commit the changed objects to the design database and quit the collaborative session.

14. Redefine the failing objects in the **FIX MODEL** dialog box if it opens. This dialog box opens if you have cleared the default selection of one or all of the redefine or suppress options in the Affected Objects panel.

**About Cross-Highlighting Selected Objects**

You can cross-highlight board objects or components of an active ECAD assembly from Pro/ENGINEER to the same design objects in InterComm Expert. To cross-highlight objects, with Pro/ENGINEER and InterComm Expert open on your computer, you must load the same assembly design in both applications.

The cross-highlight of objects from Pro/ENGINEER to InterComm Expert includes highlight, show geometry outline, and zoom. You can only highlight and zoom objects from InterComm Expert to Pro/ENGINEER. The geometry and component outlines of the selected objects are highlighted in red. You can display the changed locations of objects in InterComm Expert.

**Note:** You must set the appropriate layer visibility settings in InterComm Expert. Ensure that you have set the bookmark format to ASCII in InterComm Expert. In addition, you must also select the Cross-Highlight option in InterComm Expert.

You can select the Incremental or the Dynamic mode of communication in the Output Control panel. The Incremental mode uses the IDX file as the data
exchange format between applications. In the **Dynamic** mode, a temporary IMX online bookmarks file is automatically created when you select objects for cross-highlighting. The selected objects register a message about their location and geometry and create Image Class bookmarks with the outline data and their visible geometries.

**Note:** You cannot cross-highlight and zoom into focus board objects and outlines from the design in Pro/ENGINEER to InterComm Expert in the **Dynamic** mode.

Pro/ENGINEER uses a color scheme identical to the colors used by the baseline, current, and accepted design states for the transmission of Image Class bookmarks to InterComm Expert.

### To Cross-Highlight Selected Object Data Across Applications

1. Open an ECAD assembly in Pro/ENGINEER.
2. Open the same ECAD assembly, saved to the **ECAD EDA (*.eda)** file format, in InterComm Expert.
3. Perform the following tasks in InterComm Expert:
   a. Adjust the assembly design in the graphics window with **Browse > Zoom In** and **Zoom Out**.
   b. Click **Browse > Visibility**. The **Visibility** dialog box opens.
   c. Click **Turn all layers On** and **Apply**.
   d. Click **Browse > Options**. The **Options** dialog box opens.
   e. In the **General** tabbed page, select **ASCII Bookmarks** in the **Load/Save** section. By default, this check box is not selected.
   f. Click **Query > Cross-Highlight**.
4. In Pro/ENGINEER, click **Applications > ECAD Collaboration**.
5. To cross-highlight an object or component from InterComm Expert to Pro/ENGINEER, select the object or component in InterComm Expert. The geometry or component outline of the object or component is highlighted in red in Pro/ENGINEER.
6. To cross-highlight objects from Pro/ENGINEER to InterComm Expert, click **Output Control** on the **ECAD-MCAD Collaboration Mode** dashboard.
7. Select the **Mode** of communication as **Incremental** or **Dynamic**. **Incremental** is the default.
8. Select one of the following options from the **Objects** list or right-click and access these options from **Objects to Transmit** to select the category of objects to transmit. The selected objects are included in the message content for transmission to InterComm Expert for the cross-highlight.
   - **Selected** - Selects individual board outline objects and components. Hold down the CTRL key to select multiple objects and components. The
selection collector displays your selections. The **Send on Select** check box is available when you select this option.

Select the **Send on Select** check box to automatically transmit the selected objects to InterComm Expert.

Right-click in the selection collector, and click **Remove**, **Information**, or **Remove All** to clear the selection of an object or component, view its details, or remove all selected objects and components, respectively.

**Remove All** is available only when the collector contains more than one object or component.

- **All** - Selects all board outline objects and components of the current design.
- **On Top side** - Selects components and board objects on top of the board.
- **On Bottom side** - Selects components and board objects at the bottom of the board.

9. Select one of the following associated states of the objects selected for inclusion in the message content for transmission to InterComm Expert. Alternatively, right-click and access **Zoom**, **Highlight**, and **Object Data** from **Content to Transmit**. **Object Data** is the default.

- ![Zoom](image) - Includes the zoomed state of the selected board outline objects and components if you selected **Incremental** as the **Method** of communication.

- ![Highlight](image) - Includes the highlighted state of the selected board outline objects and components.

- ![Object Data](image) - Includes the object outline data of the selected board objects and components as Image Class bookmarks in the message content for transmission if you selected **Dynamic** as the **Method** of communication. Registers the object location and geometry.

10. Click **Send** to compose a message with the selected objects and their associated states and data and send the message to InterComm Expert. Alternatively, right-click and click **Send Transmission**.

The selected objects are cross-highlighted in red in the graphics window of InterComm Expert, with the associated state. The geometry and component outlines of the design objects and components are highlighted in red in Pro/ENGINEER too.

11. Select **Save As** to save the selected objects through the **Save a Copy** dialog box to a file to be used for offline tasks.
Controlling Import - Export with the ecad_hint.map File

About the ecad_hint.map File

The ecad_hint.map file is an ASCII file that you use to control the following functions in the ECAD import-export process:

- Substituting custom-made Pro/ENGINEER parts for automatically extruded parts on import.
- Substituting a custom-made Pro/ENGINEER MCAD assembly for an automatically extruded part, that is, an ECAD component, on import.
- Allowing or disallowing specified parts on import.
- Allowing or disallowing specified parts on export.
- Changing an ECAD reference designator to a different string for import. If, for example, the ECAD reference designator uses characters that are illegal in Pro/ENGINEER.
- Changing an ECAD other outline string for import. If, for example, the ECAD reference designator uses characters that are illegal in Pro/ENGINEER.

ECAD searches the working directory for ecad_hint.map and references it every time an import occurs. The file is ignored if it is empty or has no relevant information.

You can use the ECAD_MAPPING_FILE <path> configuration option to set a default location for the ecad_hint.map file. If you set a path with this configuration option, the working directory is not searched.

To Create the ecad_hint.map File

1. Run an automatic import of your ECAD part list into an assembly. This creates a log file called ecad_hint.add, that includes entries for each part type in the part list.

2. Edit this file, if required, substituting values as necessary, and save it in the working directory as ecad_hint.map.

3. If you have custom .prt files prepared for substitution, delete the automatically generated parts from the assembly and reimport the ECAD part file using the newly edited ecad_hint.map file.

Using the ecad_hint.add File

When ECAD creates a component .prt file automatically during import, it:

- Combines the ecad_name and ecad_alt_name as an mcad_name for the part file, and
- Records the creation of the component in a text file called ecad_hint.add.
Do not confuse this with the `ecad_hint.map` file. However, you can use the `.add` file as a template for a `.map` file.

In the `ecad_hint.add` file, each part receives the following entry (examples shown as values):

```
Map_objects_by_name ->
ECAD_NAME "CSTCS"
ECAD_ALT_NAME "N7414N"
ECAD_TYPE ""
MCAD_NAME "CSTCS_N7414N"
MCAD_TYPE "part"
END
```

Component names that include a dollar sign ($), slash (/), period (.), or percent sign (%) are not valid. Pro/ENGINEER uses the `ecad_hint.add` file to change each of these characters to an underscore (_). If this adjustment causes the file names to be identical, new file names are created. To use the translated names, edit the `ecad_hint.add` file and append it to the `ecad_hint.map` file.

If the `ecad_hint.map` file contains names that are the same except for a symbol that Pro/ENGINEER does not use, Pro/ENGINEER creates a new part name and notes this in the log file. For example, `ecad_name Aaa$` becomes `mcad_name AAA_` and `ecad_name Aaa/` becomes `mcad_name AAA_1`.

When you do not use the `ecad_hint.map` file to determine the correspondence between ECAD part names and Pro/ENGINEER part names, Pro/ENGINEER interprets the part names of components in all uppercase letters. For example, Pro/ENGINEER searches for a component named `AaaA` in an ECAD system as `AAAA`.

If you do not want the system to create an `ecad_hint.add` file, set the `ecad_create_hint_add` configuration file option to `no`.

**Using the ECAD_ALT_NAME**

ECAD parts may have the same values for `ecad_name` and different values for `ecad_alt_name`. For example, the resulting `.add` file from an import may have the following entries:

<table>
<thead>
<tr>
<th>Resistors entry 1</th>
<th>Resistors entry 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Map_objects_by_name -&gt;</td>
<td>map_objects_by_name -&gt;</td>
</tr>
<tr>
<td>ECAD_NAME &quot;Resistors&quot;</td>
<td>ECAD_NAME &quot;Resistors&quot;</td>
</tr>
<tr>
<td>ECAD_ALT_NAME &quot;R5K&quot;</td>
<td>ECAD_ALT_NAME &quot;R2K&quot;</td>
</tr>
<tr>
<td>ECAD_TYPE &quot;&quot;</td>
<td>ECAD_TYPE &quot;&quot;</td>
</tr>
<tr>
<td>MCAD_NAME &quot;RESISTORS_R5K&quot;</td>
<td>MCAD_NAME &quot;RESISTORS_R2K&quot;</td>
</tr>
<tr>
<td>MCAD_TYPE &quot;part&quot;</td>
<td>MCAD_TYPE &quot;part&quot;</td>
</tr>
<tr>
<td>End</td>
<td>End</td>
</tr>
</tbody>
</table>
In this case, if you have different models for a R5K and a R2K resistor, (for example, they may be of different colors) you can specify the individual .prt names in the ecad_alt_name field. For example, if the Pro/ENGINEER part files are called resistor1_5k.prt and resistor1_2k.prt, use the entries below:

<table>
<thead>
<tr>
<th>Resistors entry 1</th>
<th>Resistors entry 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Map_objects_by_name-&gt;</td>
<td>map_objects_by_name-&gt;</td>
</tr>
<tr>
<td>ECAD_NAME &quot;Resistors&quot;</td>
<td>ECAD_NAME &quot;Resistors&quot;</td>
</tr>
<tr>
<td>ECAD_ALT_NAME &quot;R5K&quot;</td>
<td>ECAD_ALT_NAME &quot;R2K&quot;</td>
</tr>
<tr>
<td>ECAD_TYPE &quot;&quot;</td>
<td>ECAD_TYPE &quot;&quot;</td>
</tr>
<tr>
<td>MCAD_NAME &quot;resistor1_5k&quot;</td>
<td>MCAD_NAME &quot;resistor1_2k &quot;</td>
</tr>
<tr>
<td>MCAD_TYPE &quot;part&quot;</td>
<td>MCAD_TYPE &quot;part&quot;</td>
</tr>
<tr>
<td>End</td>
<td>End</td>
</tr>
</tbody>
</table>

**Map File Standard Conventions and Examples**

In the ecad_hint.map file:

- The # character is the comment character.
- Object and value fields are separated by a space.
- Spaces are permitted in value strings if the string is surrounded by quotation marks.
- Wildcard (*) is valid for "all", for example:

```plaintext
mcad_in_ignore ->
ecad_name "resistor"
ecad_alt_name "*
ecad_type "part"
ref_des "*
end
```

- Each section begins with the purpose, followed by "->".
- Each section ends with "end". For example:

```plaintext
map_objects_by_name->

ECAD_NAME "GEN_DIP"
ECAD_ALT_NAME "GEN_DIP"
ECAD_TYPE ""
MCAD_NAME "PROE_GEN_DIP"
MCAD_TYPE "part"
end
```
To Reference Custom Parts During ECAD Import

1. In a text editor, open the ecad_hint.map file.

2. Place the name of the replacement Pro/ENGINEER component in the mcad_name section of the part's entry. The first line of each entry should be map_objects_by_name->. For example, if the Pro/ENGINEER part file you want to reference is called resistor1.prt, specify resistor1.

3. Repeat for each .prt file that you want to reference. When you run the import again, your custom parts are substituted for the automatically generated ones.

Note: Set the value of the parameter MCAD_TYPE to "ASM" if you want to substitute an MCAD assembly for an automatically extruded part.

To Control Automatic Layer Assignment

Using the ecad_hint.map file, you can specify an overriding mapping (over the automatic mapping) to produce a new ECAD_<mapped name> layer. The component is placed in that layer:

map_objects_by_name->
ECAD_NAME "eesmb"
ECAD_ALT_NAME "DM7442N"
ECAD_TYPE ""
MCAD_NAME "EESMB_DM7442N"
MCAD_TYPE "part"
MCAD_LAYER "<ANY>

Note: The ecad_comp_layer_map preferences option must be set to yes.

To Change the Other Outline String for Import

Use an entry such as the following in the ecad_hint.map file to replace an .OTHER_OUTLINE name with an MCAD name for import purposes:

map_other_outline_name->
ecd_board_name "board"
ecd_other_outline ".OTHER_OUTLINE"
mcad_part_name "heatsink"

END

To Change the Reference Designator String for Import

Use an entry such as the following in the ecad_hint.map file if a reference designator contains illegal characters. You can replace the reference designator with another string for import.

reference_designator->
To Exclude Parts From Import or Export

Use an entry such as the following in the `ecad_hint.map` file to exclude a part from import:

```
mcad_in_ignore ->
ecad_name "resistor"
ecad_alt_name "resistor_5k"
ecad_type "part"
ref_des "*
END
```

To exclude a part from export, use an entry such as the following in the `ecad_hint.map` file:

```
mcad_out_ignore ->
mcad_name "HEAT_SINK"
mcad_type part
ref_des "HS1"
END
```

Intermediate Data Format (IDF)

About the Intermediate Data Format (IDF)

The Intermediate Data Format (IDF) is a data exchange format for printed wire assemblies. IDF is available in versions 2.0 and 3.0. ECAD supports the import and export of both versions of IDF file format.

The IDF 2.0 specification does not support z-axis offset component placement information. When you export information from Pro/ENGINEER to the IDF 2.0 format, all z-axis offset information is lost.

However, IDF 3.0 supports z-offset for component placement.

About IDF File Sections

Pro/ENGINEER supports all sections of the IDF 2.0 Board File Format, and all sections of the IDF 2.0 Library File Format. All IDF 2.0 functionality supported in IDF 3.0 continues to be supported.

IDF files default to the following extensions:

- `.emn` - For a neutral file of the board outline and component placement
- `.emp` - For a profile file that contains component outlines
When you import or export with the IDF format, Pro/ENGINEER supports the Library File fields .ELECTRICAL and .MECHANICAL. Use these parameters to indicate whether an imported or exported component is electrical or mechanical. Use them in the .emp (export profile) file to set the type of component.

The system imports parts from the .OTHER_OUTLINE sections of an IDF file with default datum planes and coordinate systems at their origin. The system also imports each of them with two part parameters. The first parameter, ECAD_PART_TYPE, has the value .OTHER_OUTLINE. The second parameter, ECAD_PART_NAME, has a value equal to the name of the .OTHER_OUTLINE section where it originated.

Sometimes when you import a part, a part with the same name already exists in the current directory or session. In such cases, the part that already exists is used rather than the part specified in the IDF file.

If you prefer, you can specify another name for the system to use during import. To do this, add the lines to the ecad_hint.map file. For example, <board_name> is the name of the board part being imported, <.OTHER_OUTLINE <name>> is the name in the .OTHER_OUTLINE section of the IDF file, and <desired_name> is the name you want to use. Use this method to specify an alternative name for the .OTHER_OUTLINE part or, if the <desired_name> is the same as the name of a part in the current directory or session, specify another part to use instead of the part from the IDF file.

All .OTHER_OUTLINE parts that Pro/ENGINEER imports keep their corresponding coordinate system and name. Specify the name of the coordinate system in the .OTHER_OUTLINE section with the ecad_other_outl_csys_def_name configuration option. If you do not set this option, the system assumes that the name of the coordinate system is ECAD_DEFAULT.

The system uses the units for the ECAD system board from which this part was imported as the units for the imported part.

To export parts that you create in Pro/ENGINEER as an .OTHER_OUTLINE section, create a part parameter called ECAD_PART_TYPE, with a value of .OTHER_OUTLINE. To specify the name of the .OTHER_OUTLINE section you create when you export this part, create a second part parameter called ECAD_PART_NAME. Assign it a value equal to the name you want for the .OTHER_OUTLINE section. If you do not specify this parameter, the system specifies the name of the part being exported as the name of the .OTHER_OUTLINE section.

Exported components must have two surfaces (TOP and BOTTOM) parallel to the TOP and BOTTOM of the board in the assembly.

To export all sections specified as .DRILLED_HOLE with either the PTH (Plated Holes) or the NPTH (Non-Plated Holes) attribute in the IDF file as Through-All Hole features, set the ecad_import_holes_as_features configuration option to YES.

In IDF 2.0, the system stores all imported holes with the ECAD_HOLE_TYPE feature parameter. The value of this parameter is either PTH (plated through hole) or NPTH, (non-plated through hole) depending on the value of the .DRILLED_HOLE section in the IDF file.

IDF 3.0 uses an ECAD_PLATING_STYLE parameter similar to the ECAD_HOLE_TYPE parameter.
The system exports boards with drilled holes, created by Pro/ENGINEER, with a default value of NPTH for the ECAD_HOLE_TYPE feature parameter. Create this feature parameter to specify a value of PTH.

**Supported ECAD File Formats**

**About Supported ECAD File Formats**

ECAD supports the following ECAD systems for import to and export from ECAD. Additionally, you can use the IDF format, either 2.0 or 3.0.

- **IDF2.0** - Intermediate Data Format (IDF) specifications for version 2.0.
- **IDF3.0** - Intermediate Data Format (IDF) specifications for version 3.0.

IDF files default to the following extensions:

- .emn - For a neutral file of the board outline and component placement
- .emp - For a profile file that contains component outlines

**Note:** Board Station IDF files use the .brd and .lib extensions. If you have files with .brd or .lib extensions, ensure that you rename them to .emn and .emp, respectively, before importing them into ECAD.

Other supported formats are as follows:

- **Using the ECAD EDA Format** - This is a neutral format. You can export ECAD assemblies and Printed Circuit Board (PCB) designs to the ECAD EDA (*.eda) format. You cannot export paneled outlines to this format. The board outlines, ECAD areas, hole features, and the component profiles and placements of the ECAD assemblies are exported to the *.eda files.

- **Using the OpenAccess IC Database Format** - Three-dimensional integrated circuit (3DIC) designs for import into Pro/ENGINEER must be based on the OpenAccess (OA) Integrated Circuit (IC) database format. The 3DIC designs require the OA format (version 2.2.0) with its API library for their import to Pro/ENGINEER. The OA libraries are not distributed with Pro/ENGINEER. You must install and set up the OpenAccess (OA) libraries on your computer. The OA format stores the IC information on disk and communicates IC data between applications.

The OA-based 3DIC designs must also be based on the GDS2 standard IC format or be totally compatible with the GDS2 format. However, you must convert a GDS2 file to the OA format because you cannot directly import GDS2 files into Pro/ENGINEER. The OA package installed on your computer includes converters that allow conversions of different formats to comply with OA formats.

Use the lib.defs file for the import of the 3DIC designs into Pro/ENGINEER. This file contains the design information and is the top-level file that includes the directory names of the OA libraries.

- **Using the Boardstation Format** - Uses versions 1.0 and 2.0 of Intermediate Data Format (IDF) from Mentor to interface with the Mentor Graphics Board
Station software. The `mentor-ver_2_0` configuration option controls whether Pro/ENGINEER data is exported in version 1.0 or version 2.0 format.

Pro/ENGINEER accepts exported information from Mentor Graphics that uses the 3D Mechanical interface. See your Mentor Graphics documentation for more information.

**Accessing Legacy File Formats**

**About Accessing Legacy Formats**

The Allegro, Dazix, and Visula formats are not available, by default, in the **File Open** and **Save a Copy** dialog boxes for import and export operations in the part and assembly modes of Pro/ENGINEER. You must set the `ecad_use_legacy_formats` configuration option to `yes` to access the following formats in these dialog boxes:

- **The Visula Format** - Use the Visula ECAD/MCAD Neutral Interface format to interface with the Visula version 6.0 software from Zuken-Redac Systems.

- **The Allegro Format** - Use the Allegro Interface format to interface with Allegro version 5.1 and later from Cadence Design Systems. Cadence recommends that all users use IDF 2.0.

- **The Dazix Format** - Supports the interface with:
  - CDX Classic software (formerly Dazix CDX Classic)
  - **AT Designer** - Intergraph Corporation v 12 through v12.3, (formerly PCB Engineer). V12.4 and later use the IDF 2.0 format.

**About Using the Allegro Format**

**Note:** Cadence and PTC recommend that you use the IDF format for data exchange, not the older direct format.

Allegro files have one of the following extensions:

- `.mdb` - For board outline files
- `.mdc` - For component placement files
- `.mdf` - For footprint files, such as the ones in component outline libraries

You must set the `ecad_use_legacy_formats` configuration option to `yes` to access the Allegro file formats in the **File Open** and **Save a Copy** import and export dialog boxes.

Allegro cannot read the outlines of components. In part mode, you can only export boards to Allegro. Allegro represents mounting holes and other such features on a board as components. Therefore, component placement files contain their placement information.

To process these features properly, Pro/ENGINEER requires the diameter of the holes, even though Allegro does not write this information to these interface files. To work
around this, include a special record in the ecad_hint.map file. This record is called map_hole_component and is formatted as follows:

map_hole_component ->
ecad_name "hole_name"
ecad_type ""
unit "unit_name"
diameter "diam_value"

End

For example:
map_hole_component ->
ecad_name "MH125"
ecad_type ""
unit "mil"
diameter "125"

End

To support the diameter of the holes, write the following units in the ecad_hint.map file:

- mm
- in
- mils

All other Pro/ENGINEER units are converted as follows:

- cm converted to mm
- m converted to mm
- ft converted to mils
- microns converted to mils

For example, a Pro/ENGINEER part with a hole diameter of 1.5 inches can have an Allegro ecad_hint.map file as follows:

map_hole_component ->
ecad_name "kuku"
ecad_type ""
unit "ft"
diameter "0.125"

End

or

map_hole_component ->
ecad_name "kuku"
ecad_type ""
When Pro/ENGINEER exports ECAD models to Allegro, it places a warning in the ECAD export log file if the export model contains area types that Allegro does not support. Allegro ignores the unsupported area types.

Note: The Allegro interface format does not specify height information for placement keepin and keepout areas. Even if Pro/ENGINEER contains this information, Pro/ENGINEER cannot export it to Allegro.

About Using the Dazix Format

Dazix files use the following extensions:

- .edn - For a neutral file of the board outline and component placement. Dazix refers to this as a core file.
- .edp - For a profile file that contains component outlines. Dazix refers to this as a library file.

You must set the ecad_use_legacy_formats configuration option to yes to access the Dazix file formats in the File Open and Save a Copy import and export dialog boxes. Dazix component names are mixed-case, prefixed with Z. Pro/ENGINEER converts these names to all uppercase. However, Dazix does not recognize uppercase names. Thus, to effect the transfer of component data, Dazix automatically creates an ecad_hint.map file.

Note: The Dazix interface format does not specify placement keepin areas or height information for placement keepout areas. Even if Pro/ENGINEER contains this information, Pro/ENGINEER cannot export it to Dazix.

About Using the Visula Format

All Visula files use the extension .evs. You must set the ecad_use_legacy_formats configuration option to yes to access the Visula format in the File Open and Save a Copy import and export dialog boxes.

The Visula interface format does not specify package keepout areas. Even if you create such an area in Pro/ENGINEER, Pro/ENGINEER does not export it. The IDF 2.0 format, however, does specify keepout areas.
## Glossary

### Glossary for ECAD

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assembly design</td>
<td>A graphic representation of a group of CAD models, an engineering or manufacturing model, or workpiece in the context of an assembly. It defines the geometry of the individual component parts of a product. The assembly design allows multiple engineers to work on the components of the assembly, shortening design time.</td>
</tr>
<tr>
<td>Baseline design</td>
<td>A design revision state used as a starting point for change. A benchmark used as the basis for comparison. It is the known state of the design and the reference state. The current design is compared with the baseline design.</td>
</tr>
<tr>
<td>Board</td>
<td>A rigid and flat structure that provides physical electrical connectivity between the pins of various components located on either surface of a Printed Circuit Board (PCB). All components are placed on the board. It is an electrical equipment panel.</td>
</tr>
<tr>
<td>Board outline</td>
<td>Geometry that describes the external shape of a PCB. A physical outline of the PCB. It is also the base of a PCB.</td>
</tr>
<tr>
<td>Bookmark</td>
<td>A temporary snapshot of the current state of a design. It contains user markups and the various states of the application and its database.</td>
</tr>
<tr>
<td>Bookmark file</td>
<td>A file with one or more bookmarks, saved with a <code>.imx</code> extension. You can save important links in a bookmark file so that you can access them instantly without typing the Web address.</td>
</tr>
<tr>
<td>Collaborative environment</td>
<td>The associative interoperability of ECAD tools with Pro/ENGINEER. It enables concurrent engineering in a collaborative manner. It provides a highly iterative design development environment and offers electronic collaboration capabilities. It also allows two or more individuals with complementary skills to create a shared understanding with a common purpose and goal and achieve synchronization and sharing of information at realtime.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Component outline</td>
<td>The shape that represents an object on a PCB or electrical design, considered for placement and routing.</td>
</tr>
<tr>
<td>Component placement</td>
<td>The positioning of a part or subassembly in an assembly. Components are arranged relative to each other through placement constraints and references. A good component placement can have an impact on design quality and manufacturability. A PCB designer places components for optimum routability, manufacturability, and signal timing.</td>
</tr>
<tr>
<td>Cross-highlight</td>
<td>A mechanism that enables product teams to visually collaborate across the electronic design automation (EDA) process. The ECAD-MCAD Collaboration allows the highlight and zoom of objects from Pro/ENGINEER to InterComm Expert and vice-versa. Offers a work-in-process design review. Development teams are able to communicate design intent and cross-probe design data across applications.</td>
</tr>
<tr>
<td>Cross-section</td>
<td>A view of the internal structure of a model created by a plane cutting through an assembly or part.</td>
</tr>
<tr>
<td>Current design</td>
<td>The active or the current design data that is compared with the baseline design in a collaborative environment. It represents the design that is currently being worked on.</td>
</tr>
<tr>
<td>ECAD assembly</td>
<td>An assembly with ECAD data. The assembly can include PCB designs and can be a board assembly with keypads, connectors, pin holes, and other components. It includes circuit board geometry and can be designed in the mechanical assembly of the product, including mounting holes and constraints areas.</td>
</tr>
<tr>
<td>IDX format</td>
<td>The Incremental Design Exchange format. It is an XML-based messaging format that is based on the ProSTEP EDMD (ECAD Design and MCAD Design) open schema for the incremental exchange of PCB layout changes between MCAD and ECAD tools.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>IMX format</td>
<td>Format of a bookmark file.</td>
</tr>
<tr>
<td>Incremental change</td>
<td>Differences that are defined as the subtraction between the current design and the saved design. Alternatively, a series of small changes. A change is a proposed new state of an object in an MCAD or ECAD design.</td>
</tr>
<tr>
<td>InterComm Expert</td>
<td>The neutral viewer for 2D ECAD data. It allows quick verification of electronic design intent between engineering, design, fabrication, testing, and assembly departments. InterComm Expert queries ECAD design data and verifies design intent. It cross-highlights between the schematic, layout, and bill-of-materials. It communicates changes, comments, or red-line data.</td>
</tr>
<tr>
<td>MCAD</td>
<td>Mechanical Computer Aided Design. A CAD tool for designing mechanical assemblies in a mechanical domain.</td>
</tr>
<tr>
<td>Panel</td>
<td>An ECAD entity comprising multiple boards. Piece of material, usually an epoxy-copper laminate known as FR-4, sized for the fabrication of printed circuit boards. The most common panel size is 12 inches by 18 inches, of which 11 inches by 17 inches is available for printed circuitry.</td>
</tr>
<tr>
<td>Performance of assembly</td>
<td>Model retrieval time that is critical to product development. The time an assembly takes for component placement, update, redefinition, and regeneration.</td>
</tr>
<tr>
<td>Printed Circuit Board (PCB)</td>
<td>An electronic subassembly consisting of an insulating board or card and circuit components, such as diodes and integrated circuits, that you can attach and connect in different ways. It is a rigid, flat board, made from fiberglass, approximately 0.060 inches thick. It is used for mounting electronics components as part of a larger assembly. It has integrated circuits, transistors, resistors, capacitors, diodes, and similar electronic devices mounted on it. It can also consist of layers of fiberglass and copper with the required circuit connections etched into the copper layers. It is usually green in color and provides electrical connectivity between the pins of various components located on either surface of the board.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>PCB design</td>
<td>A design of the physical layout of a Printed Circuit Board in the ECAD domain.</td>
</tr>
<tr>
<td>ProductView ECAD Compare</td>
<td>A utility in Pro/ENGINEER that loads two existing ECAD assembly design files, compares them, and generates an IDX file with the results of the comparison.</td>
</tr>
<tr>
<td>Pro/ENGINEER ECAD assembly</td>
<td>A Pro/ENGINEER assembly with ECAD data.</td>
</tr>
<tr>
<td>Reference designator</td>
<td>A unique identifier that is assigned to a component in a design to distinguish it from other components of the same type and also locate it on the schematic, board layout, or parts list. These identifiers usually begin with an alphabetic character that denotes the type of component, such as R for resistor, C for capacitor, and U for microcircuit, followed by a numeric designator. Reference designators are used in schematic and PCB layouts to label components.</td>
</tr>
<tr>
<td>Rich 3D component model</td>
<td>The addition of electronic catalogs and parts manuals to 3D models create rich 3D models. It is the seamless integration of interactive 3D components with animated 3D graphics. Text and graphics, audio and video, animation and 3D models are well integrated. This integration provides a high level of interaction between the electronic and the mechanical design processes. The rich 3D component model offers a data-rich exchange of information between the electronic and the mechanical systems. Rich 3D models are vital to the ECAD-MCAD design integration.</td>
</tr>
<tr>
<td>Subassembly</td>
<td>The descendant of an assembly. A subdivision of an assembly consisting of a package of parts, elements, and circuits that performs a specific function. A logical grouping of parts that is part of the total assembly.</td>
</tr>
</tbody>
</table>
Index

3

3DIC designs
converting GDS2 files ................. 42
importing 3DIC designs ..........38, 39
instancing IC structures ..........38, 39
limitations in visualization ........ 42
placing IC layers and structures .. 38, 39
transforming IC structure instances ............................................ 39
troubleshooting import .......... 43
troubleshooting installation ...... 43
using OpenAccess format .......... 42
visualizing imported designs .... 39
3DIC designs .......................................................... 38
3DIC designs .......................................................... 39
3DIC designs .......................................................... 39
3DIC designs .......................................................... 42
C
clearance-interference check .......... 8
collaborative environment
analyzing changed data ... 61, 63, 70
comparing designs ................. 59
cross-highlight object data .....69, 70
ECAD-MCAD workflows .... 56, 57, 58
generating IDX file ..........59, 61
proposing design changes .....57, 58
tasks you can perform 55, 59, 61, 64, 68, 69
updating ECAD assembly 64, 65, 66, 68
Using ProductView ECAD Compare 59, 60
using ProductView Validate .... 61, 64
collaborative environment ..........55
collaborative environment ..........56
E
ECAD
configuration options ................. 9
keepin and keepout areas.25, 45, 46
parameters for ............... 5, 6, 8, 47
using ECAD_ALT_NAME configuration option ................................73
using ECADcompare utility ..........59
ECAD .......................................................... 2, 3
ECAD .......................................................... 78
ECAD Export
exporting board or parts..47, 48, 50, 76
exporting board outlines ...... 51, 53
exporting ECAD data. 47, 48, 51, 52, 53, 54
exporting IDF .emn and .emp files 51
exporting irregularly shaped models .........................................54
exporting PCB designs ............ 47, 51
exporting to .eda file format . 51, 52, 53, 54, 59
supported formats ..... 76, 78, 79, 81
ECAD Export ................................................. 47
ECAD Import
3-dimensional integrated circuit designs .......... 38, 39, 42, 43
assembly coordinate systems ...... 19
categorizing holes...............31, 32
component coordinate systems... 17, 19
configuring hole import... 12, 13, 31, 36, 37
Defining hole filtration rules ...31, 34
ecad_hint.add file ...................... 72
ecad_hint.map file .......... 72, 74, 75
filtering holes by category 31, 32, 34
filtering holes by diameter......31, 34
fixing import contours ..........4
importing a PCB or panel assembly ...........................................13, 20
importing ECAD Components.. 3, 14, 20, 22, 23, 25, 29, 75, 76
importing holes by category ...31, 32
importing holes of board outlines 31, 32, 36, 37
importing other outlines.........35
investigate mode ......................29
layer assignment ............ 14, 16, 75
log file........................................5
prioritizing hole import ... 32, 36, 37
supported formats14, 42, 76, 78, 79, 81
troubleshooting 3DIC design import ...........................................43
ECAD Import..................................2
ECAD Import................................ 14
ECAD-MCAD Collaboration Mode
  about board geometry changes... 64, 66, 68
  accepting design changes ......64, 65
  comparing designs.............. 59, 62
  creating IMX bookmarks file... 69, 70
cross-highlighting design objects.61, 63, 69, 70
ecad-mcad workflows. 55, 56, 57, 58
entering the mode.......................55
handling feature failures...64, 66, 68
performing collaborative tasks55, 57, 58, 59, 63, 65, 68, 70
previewing design states ...............63
proposing design changes55, 57, 58, 59, 61
redefining objects..............65, 66, 68
rejecting design changes....... 63, 65
resolving downstream issues. 65, 66, 67, 68
selecting objects for transmission 69, 70
setting baseline...............51, 59, 62
setting bookmarks format to ASCII ...........................................69, 70
setting preview levels ..........67
suppressing objects .............66, 68
transmitting objects.......... 69, 70
updating assembly database. 64, 65, 66, 68
updatingIDX file ............... 64, 65
using IDX file........ 57, 58, 59, 61
using online bookmarks file ... 69, 70
using ProductView ECAD Compare59, 60, 61
using ProductView Validate... 60, 61, 63, 64, 65
validating proposed changes . 61, 62, 63, 69, 70
Index

ECAD-MCAD Collaboration Mode ....... 2
ECAD-MCAD Collaboration Mode ..... 55
ECAD-MCAD Collaboration Mode ..... 56
electrical components .......... 2, 14, 26
L
legacy formats
  using Allegro format ............ 79
  using Dazix format .......... 79, 81
  using Visula format .......... 79, 81
  legacy formats ................. 79
  legacy formats ................. 79
  legacy formats ................. 81
  legacy formats ................. 81
R
reference designators ......... 26, 27, 59